Bug 1340596 - mesa-dri-drivers broken dependencies in RHEL 7.3
Summary: mesa-dri-drivers broken dependencies in RHEL 7.3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mesa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Dave Airlie
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1340407
TreeView+ depends on / blocked
 
Reported: 2016-05-28 10:43 UTC by Richard W.M. Jones
Modified: 2016-11-09 15:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-01 10:12:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Richard W.M. Jones 2016-05-28 10:43:53 UTC
Description of problem:

Can't build a RHEL 7.3 live CD at the moment because of
various mesa brokenness:

mesa-libxatracker-10.6.5-3.20150824.el7.x86_64 requires libLLVM-3.6-mesa.so()(64bit)
mesa-libxatracker-10.6.5-3.20150824.el7.x86_64 requires libLLVM-3.6-mesa.so(libLLVM-3.6-mesa.so)(64bit)

and:

mesa-dri-drivers-10.6.5-3.20150824.el7.x86_64 requires libLLVM-3.6-mesa.so()(64bit)
Dmesa-libxatracker-10.6.5-3.20150824.el7.x86_64 requires libLLVM-3.6-mesa.so()(64bit)
mesa-dri-drivers-10.6.5-3.20150824.el7.x86_64 requires libLLVM-3.6-mesa.so(libLLVM-3.6-mesa.so)(64bit)
mesa-libxatracker-10.6.5-3.20150824.el7.x86_64 requires libLLVM-3.6-mesa.so(libLLVM-3.6-mesa.so)(64bit)

Version-Release number of selected component (if applicable):

As above.

How reproducible:

100%

Steps to Reproduce:
1. Build a live CD eg with 'brew spin-livecd ... rhel-7.3-candidate' command.

Comment 3 Dave Airlie 2016-06-01 04:44:10 UTC
This just looks like bad packages in the buildroot I've untagged one now to see if it helps.

Comment 4 Richard W.M. Jones 2016-06-01 10:12:09 UTC
Yup looking good now, thanks.

Comment 5 prasun.gera 2016-11-09 15:44:14 UTC
This still seems to be broken in 7.3 GA. I'm trying to downgrade libdrm, but I'm not able to. 

sudo yum downgrade drm-utils libdrm libdrm-devel mesa-dri-drivers

Resolving Dependencies
--> Running transaction check
---> Package drm-utils.x86_64 0:2.4.60-3.el7 will be a downgrade
---> Package drm-utils.x86_64 0:2.4.67-3.el7 will be erased
---> Package libdrm.x86_64 0:2.4.60-3.el7 will be a downgrade
---> Package libdrm.x86_64 0:2.4.67-3.el7 will be erased
---> Package libdrm-devel.x86_64 0:2.4.60-3.el7 will be a downgrade
---> Package libdrm-devel.x86_64 0:2.4.67-3.el7 will be erased
---> Package mesa-dri-drivers.x86_64 0:10.6.5-3.20150824.el7 will be a downgrade
--> Processing Dependency: libLLVM-3.6-mesa.so(libLLVM-3.6-mesa.so)(64bit) for package: mesa-dri-drivers-10.6.5-3.20150824.el7.x86_64
--> Processing Dependency: libLLVM-3.6-mesa.so()(64bit) for package: mesa-dri-drivers-10.6.5-3.20150824.el7.x86_64
---> Package mesa-dri-drivers.x86_64 0:11.2.2-2.20160614.el7 will be erased
--> Finished Dependency Resolution
Error: Package: mesa-dri-drivers-10.6.5-3.20150824.el7.x86_64 (rhel-x86_64-server-7)
           Requires: libLLVM-3.6-mesa.so(libLLVM-3.6-mesa.so)(64bit)
           Available: mesa-private-llvm-3.6.2-2.el7.x86_64 (rhel-x86_64-server-7)
               libLLVM-3.6-mesa.so(libLLVM-3.6-mesa.so)(64bit)
           Installed: mesa-private-llvm-3.8.1-1.el7.x86_64 (@rhel-x86_64-server-7)
               Not found
           Available: mesa-private-llvm-3.3-0.8.20131023.el7.i686 (rhel-x86_64-server-7)
               Not found
           Available: mesa-private-llvm-3.5.0-1.el7.i686 (rhel-x86_64-server-7)
               Not found
Error: Package: mesa-dri-drivers-10.6.5-3.20150824.el7.x86_64 (rhel-x86_64-server-7)
           Requires: libLLVM-3.6-mesa.so()(64bit)
           Available: mesa-private-llvm-3.6.2-2.el7.x86_64 (rhel-x86_64-server-7)
               libLLVM-3.6-mesa.so()(64bit)
           Installed: mesa-private-llvm-3.8.1-1.el7.x86_64 (@rhel-x86_64-server-7)
              ~libLLVM-3.8-mesa.so()(64bit)
           Available: mesa-private-llvm-3.3-0.8.20131023.el7.i686 (rhel-x86_64-server-7)
               Not found
           Available: mesa-private-llvm-3.5.0-1.el7.i686 (rhel-x86_64-server-7)
               Not found
 You could try using --skip-broken to work around the problem


Note You need to log in before you can comment on or make changes to this bug.