Bug 1340717 - Backport to liberty: set of no-downtime patches for ovs neutron agent
Summary: Backport to liberty: set of no-downtime patches for ovs neutron agent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: async
: 8.0 (Liberty)
Assignee: Hynek Mlnarik
QA Contact: Toni Freger
URL:
Whiteboard:
: 1343106 (view as bug list)
Depends On: 1341958
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-30 07:20 UTC by Hynek Mlnarik
Modified: 2019-11-14 08:12 UTC (History)
9 users (show)

Fixed In Version: openstack-neutron-7.0.4-7.el7ost
Doc Type: Enhancement
Doc Text:
This update removes unnecessary downtime caused by updating OvS switch reconfiguration when restarting the OvS agent. Previously, dropping flows on physical bridges caused networking to drop. The same issue was experienced when the patch port between br-int and br-tun was deleted and rebuilt during startup. This enhancement resolves these issues, making it possible to restart the OvS agent without unnecessarily disrupting network traffic. This results in no downtime when restarting the OvS neutron agent if the bridge is already set up and reconfiguration was not requested.
Clone Of:
Environment:
Last Closed: 2016-06-29 13:59:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1514056 0 None None None 2016-05-30 07:20:58 UTC
OpenStack gerrit 299280 0 None None None 2016-05-30 07:24:49 UTC
OpenStack gerrit 300424 0 None None None 2016-05-30 07:25:12 UTC
OpenStack gerrit 306041 0 None None None 2016-05-30 07:25:38 UTC
OpenStack gerrit 319545 0 None None None 2016-06-06 11:15:37 UTC
Red Hat Product Errata RHBA-2016:1353 0 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2016-06-29 17:57:46 UTC

Description Hynek Mlnarik 2016-05-30 07:20:59 UTC
Dropping flows on the the physical bridges causes networking to drop. It's one of the two places that still causes networking to drop when OVS agent is restarted. The other is that the patch port between br-int and br-tun is being deleted and rebuilt during startup.

This issue prevents no-downtime upgrades. It has been fixed in upstream and backported to stable/liberty branch. As there is not known plan for next stable RHEL OSP 8 release, the relevant patches are going to be backported proactively.

Comment 2 Assaf Muller 2016-06-06 16:09:30 UTC
*** Bug 1343106 has been marked as a duplicate of this bug. ***

Comment 5 Toni Freger 2016-06-23 11:16:27 UTC
The code tested in latest OSP8 - openstack-neutron-7.0.4-7.el7ost.noarch

Comment 7 errata-xmlrpc 2016-06-29 13:59:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1353


Note You need to log in before you can comment on or make changes to this bug.