Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1341958 - Backport to liberty: Native ovsdb implementation not working
Summary: Backport to liberty: Native ovsdb implementation not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: async
: 8.0 (Liberty)
Assignee: Hynek Mlnarik
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks: 1340717
TreeView+ depends on / blocked
 
Reported: 2016-06-02 07:13 UTC by Hynek Mlnarik
Modified: 2019-02-17 12:12 UTC (History)
8 users (show)

Fixed In Version: openstack-neutron-7.0.4-7.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, connectivity would never be enabled when attempting to use the new native OVSDB provider due to the db_set operation appearing to fail to change the patch ports from "nonexistant-peer" to the correct peer, thereby not linking the bridges together. This was caused by an incorrect method being used to set the peer interface of an OVS bridge. With this update, the peer option is now correctly set for both native and vsctl interfaces.
Clone Of:
Environment:
Last Closed: 2016-06-29 13:59:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1528894 0 None None None 2016-06-02 07:13:10 UTC
OpenStack gerrit 297343 0 None None None 2016-06-02 07:14:22 UTC
Red Hat Product Errata RHBA-2016:1353 0 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2016-06-29 17:57:46 UTC

Description Hynek Mlnarik 2016-06-02 07:13:10 UTC
When trying to use the new native OVSDB provider, the connectivity never goes up due to the fact that what seems to be the db_set operation failing to change the patch ports from "nonexistant-peer" to the correct peer, therefore not linking the bridges together.

When using the following openvswitch agent configuration:

  [OVS]
  ovsdb_interface = ovsdb

Restarting the OVS agent will setup everything but leave network in a failed state because the correct patch ports aren't updated:

# ovs-vsctl show
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "em1"
            Interface "em1"
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=nonexistent-peer}
    Bridge br-int
        fail_mode: secure
        Port "qvo25d28228-9c"
            tag: 1
            Interface "qvo25d28228-9c"
...
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=nonexistent-peer}

Configuration using ovs vsctl interface works with no problems.

This issue renders ovsdb native interface unusable. It has been fixed in upstream and backported to stable/liberty branch. As there is not known plan for next stable RHEL OSP 8 release, the relevant patches are going to be backported proactively.

Comment 2 Ihar Hrachyshka 2016-06-13 09:11:10 UTC
Why do we care about the issue in OSP context? Do we use native interface anywhere?

Comment 3 Hynek Mlnarik 2016-06-13 09:12:52 UTC
Yes, in functional tests. Namely functional tests for bug 1340717 fail if this patch is not included.

Comment 6 Toni Freger 2016-06-23 10:29:18 UTC
Code tested in latest OSP8 - openstack-neutron-7.0.4-7.el7ost

Comment 8 errata-xmlrpc 2016-06-29 13:59:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1353


Note You need to log in before you can comment on or make changes to this bug.