Bug 1340953 - Eclipse CDT Standalone Debugger crashes.
Summary: Eclipse CDT Standalone Debugger crashes.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1341514 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-30 22:00 UTC by Onuralp SEZER
Modified: 2016-06-18 18:38 UTC (History)
7 users (show)

Fixed In Version: eclipse-cdt-9.0.0-0.8.gitdff6b3b.fc24 eclipse-cdt-9.0.0-0.9.gitdff6b3b.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-18 18:38:30 UTC


Attachments (Terms of Use)
Eclipse cdt crash log generated by eclipse itself. (8.81 KB, text/plain)
2016-05-30 22:00 UTC, Onuralp SEZER
no flags Details
Crash log for CDT Standalone Debugger. (8.79 KB, text/plain)
2016-06-01 15:45 UTC, Onuralp SEZER
no flags Details
Eclipse cdt crash log for latest packge (8.20 KB, text/plain)
2016-06-03 20:48 UTC, Onuralp SEZER
no flags Details
Debugger log (6.42 KB, text/plain)
2016-06-03 21:54 UTC, Onuralp SEZER
no flags Details

Description Onuralp SEZER 2016-05-30 22:00:14 UTC
Created attachment 1162986 [details]
Eclipse cdt crash log generated by eclipse itself.

Description of problem:
Eclipse Arduino Cdt plugin crashes always because list of error in attachment.

Version-Release number of selected component (if applicable):

eclipse-cdt-arduino-9.0.0-0.6.gitdff6b3b.fc24.x86_64


How reproducible:
Open Eclipse CDT and crashed


Actual results:
Eclipse crashed and give error reports

Expected results:
Eclipse Cdt should load-up work normally. 

Additional info:
When I starting to reporting this problem I also notice there no package for "eclipse-cdt-arduino" on bug report so If It's wrong I need to open another ticket for this problem for adding package on the list for future.

Thank you.

Comment 1 Jeff Johnston 2016-05-31 02:03:41 UTC
(In reply to ONURALP SEZER from comment #0)
> Created attachment 1162986 [details]
> Eclipse cdt crash log generated by eclipse itself.
> 
> Description of problem:
> Eclipse Arduino Cdt plugin crashes always because list of error in
> attachment.
> 
> Version-Release number of selected component (if applicable):
> 
> eclipse-cdt-arduino-9.0.0-0.6.gitdff6b3b.fc24.x86_64
> 
> 
> How reproducible:
> Open Eclipse CDT and crashed
> 
> 
> Actual results:
> Eclipse crashed and give error reports
> 
> Expected results:
> Eclipse Cdt should load-up work normally. 
> 
> Additional info:
> When I starting to reporting this problem I also notice there no package for
> "eclipse-cdt-arduino" on bug report so If It's wrong I need to open another
> ticket for this problem for adding package on the list for future.
> 
> Thank you.

Your attachment appears to be running the CDT standalone debugger and not Eclipse by itself.  The problem you have is also due to org.eclipse.launchbar.core missing.  Did you include the wrong attachment or is the description incorrect?

Comment 2 Onuralp SEZER 2016-05-31 06:01:56 UTC
Ohh I didn't notice that that was debugger. Because when I install CDT I just get 2 desktop icon and I can't read all because of gnome3 minimize the name of it. Well I can still say I can't see anything behalf of cdt-arduino itself. Because looks like plugin not even activated. 

Attachment is correct. Description need to change so for that bug I can say "debugger" is not working. If It's already reported. We can say It's duplicate. If not please change description title and then anything you need I need to provide please say so I can uplaod it. 

Thank you.

Comment 3 Fedora Update System 2016-05-31 20:18:00 UTC
eclipse-cdt-9.0.0-0.7.gitdff6b3b.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-66e4af5a88

Comment 4 Fedora Update System 2016-06-01 08:28:52 UTC
eclipse-cdt-9.0.0-0.7.gitdff6b3b.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-66e4af5a88

Comment 5 Onuralp SEZER 2016-06-01 15:45:02 UTC
Created attachment 1163736 [details]
Crash log for CDT Standalone Debugger.

I updated package to eclipse-cdt-1:9.0.0-0.7.gitdff6b3b.fc24.x86_64 and problem happen again.

Comment 6 Jeff Johnston 2016-06-01 15:54:11 UTC
(In reply to ONURALP SEZER from comment #5)
> Created attachment 1163736 [details]
> Crash log for CDT Standalone Debugger.
> 
> I updated package to eclipse-cdt-1:9.0.0-0.7.gitdff6b3b.fc24.x86_64 and
> problem happen again.

Can you verify if eclipse-launchbar is installed:

  rpm -q eclipse-launchbar

and what version it is.  The fix I provided in the new eclipse-cdt package was to require the eclipse-launchbar package which contains the org.eclipse.launchbar.core plug-in your trace is reporting missing.

Comment 7 Onuralp SEZER 2016-06-01 16:00:29 UTC
I already installed and fpaste result : 

http://paste.fedoraproject.org/373420/46479673

Comment 8 Jeff Johnston 2016-06-02 20:49:34 UTC
(In reply to ONURALP SEZER from comment #7)
> I already installed and fpaste result : 
> 
> http://paste.fedoraproject.org/373420/46479673

I found the problem.  F24 uses droplets and the config.ini file needs to explicitly state where org.eclipse.launchbar.core comes from.  I have tried this and the standalone debugger comes up.

I will post a fix later today.

Comment 9 Onuralp SEZER 2016-06-02 20:55:54 UTC
Thank you.

Comment 10 Fedora Update System 2016-06-03 15:07:13 UTC
eclipse-cdt-9.0.0-0.8.gitdff6b3b.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef69d4aacd

Comment 11 Onuralp SEZER 2016-06-03 20:48:06 UTC
Created attachment 1164636 [details]
Eclipse cdt crash log for latest packge

Only launchbar give error and others looks like fix but still problem continue

Comment 12 Jeff Johnston 2016-06-03 21:26:47 UTC
Ah, I fixed this incorrectly.  While this worked for me, the plugins (org.eclipse.launchbar.core and org.eclipse.ui.views.log) should be set by the cdtdebug script and not set in the rpm build since they specify a specific versioned jar.  If you edit your config.ini file in your fcdtdebugger directory and set the actual launchbar version you have installed, you should be able to work around this issue before the fix is available.

Comment 13 Onuralp SEZER 2016-06-03 21:54:31 UTC
Created attachment 1164639 [details]
Debugger log

I changed that and not see any launchbar problem but It's asking so many other cdt packages too. I have to change them all If I want to use of it.

Comment 14 Jeff Johnston 2016-06-04 00:25:00 UTC
You can try moving your fcdtdebugger directory first.  I found I had to do that when I was testing.   Anyways, I still need to work on the correct patch.

Comment 15 Fedora Update System 2016-06-04 18:26:01 UTC
eclipse-cdt-9.0.0-0.8.gitdff6b3b.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef69d4aacd

Comment 16 Fedora Update System 2016-06-07 22:58:49 UTC
eclipse-cdt-9.0.0-0.9.gitdff6b3b.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-87ae35a3ee

Comment 17 Onuralp SEZER 2016-06-08 14:46:45 UTC
Log report.... When I update the package I'm using workaround way for now. 

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.490
!MESSAGE Bundle org.eclipse.ui.views.log not found.

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.493
!MESSAGE Bundle org.apache.lucene.analysis not found.

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.504
!MESSAGE Bundle com.google.gson not found.

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.504
!MESSAGE Bundle org.eclipse.launchbar.core not found.

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
!MESSAGE Bundle org.apache.xalan not found.

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
!MESSAGE Bundle org.apache.xerces not found.

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
!MESSAGE Bundle org.apache.xml.resolver not found.

!ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
!MESSAGE Bundle org.apache.xml.serializer not found.

Comment 18 Jeff Johnston 2016-06-08 16:22:49 UTC
(In reply to ONURALP SEZER from comment #17)
> Log report.... When I update the package I'm using workaround way for now. 
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.490
> !MESSAGE Bundle org.eclipse.ui.views.log not found.
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.493
> !MESSAGE Bundle org.apache.lucene.analysis not found.
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.504
> !MESSAGE Bundle com.google.gson not found.
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.504
> !MESSAGE Bundle org.eclipse.launchbar.core not found.
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
> !MESSAGE Bundle org.apache.xalan not found.
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
> !MESSAGE Bundle org.apache.xerces not found.
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
> !MESSAGE Bundle org.apache.xml.resolver not found.
> 
> !ENTRY org.eclipse.osgi 4 0 2016-06-08 17:42:40.505
> !MESSAGE Bundle org.apache.xml.serializer not found.

Are you using the last 0.9 version?  You should not be seeing the lucene.analysis statement because it is no longer referenced in config.ini.  Did you remove your fcdtdebugger directory before re-trying?  I have this working on a F24 VM and it removed all the error messages above.  If you can log in as root, add the -x option to the first line (!/bin/sh) of the /usr/bin/cdtdebug script and post what you see output.  As well, please confirm that you have the 0.9 version installed.

Comment 19 Fedora Update System 2016-06-08 17:55:35 UTC
eclipse-cdt-9.0.0-0.9.gitdff6b3b.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-87ae35a3ee

Comment 20 Onuralp SEZER 2016-06-08 19:10:42 UTC
I'm sorry I used version 9.0.0-0.6 and I updated to latest delete the old log files and It's now working. Thank you so much .

$ rpm -q eclipse-cdt
eclipse-cdt-9.0.0-0.9.gitdff6b3b.fc24.x86_64

Comment 21 Roland Grunberg 2016-06-13 14:08:18 UTC
*** Bug 1341514 has been marked as a duplicate of this bug. ***

Comment 22 Fedora Update System 2016-06-18 18:38:27 UTC
eclipse-cdt-9.0.0-0.9.gitdff6b3b.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.