Bug 1341514 - Eclipse cdt does not start, it requires to install eclipse-cdt-sdk
Summary: Eclipse cdt does not start, it requires to install eclipse-cdt-sdk
Keywords:
Status: CLOSED DUPLICATE of bug 1340953
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-01 08:33 UTC by spital
Modified: 2016-06-13 14:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-13 14:08:18 UTC


Attachments (Terms of Use)

Description spital 2016-06-01 08:33:28 UTC
Description of problem:
Eclipse cdt does not start, it requires to install eclipse-cdt-sdk

Version-Release number of selected component (if applicable):
Fedora 24 beta


Steps to Reproduce:
1. sudo dnf -y install eclipse-cdt
2. eclipse


Actual results:

!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.cdt.debug.application.app" could not be found in the registry. The applications available are:
 .....
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
	at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
....

Expected results:

eclipse just starts without error

Additional info:

sudo dnf -y install eclipse-cdt-sdk
helped

Comment 1 Roland Grunberg 2016-06-01 13:42:46 UTC
Could this be the same issue as Bug 1340953 ? There appears to be a build that solves this in updates-testing.

Comment 2 spital 2016-06-05 07:53:07 UTC
I can confirm a fresh install of FC24 works fine and dnf -y install eclipse-cdt was enough to have working Eclipse neon.
No eclipse-cdt-sdk present through rpm -qa | grep eclipse | grep sdk

Comment 3 Roland Grunberg 2016-06-13 14:08:18 UTC
Closing as a duplicate of Bug 1340953 since the work to resolve this (if any is remaining) will likely be done there.

*** This bug has been marked as a duplicate of bug 1340953 ***


Note You need to log in before you can comment on or make changes to this bug.