Bug 1341170 - [OSP-director] nova ec2-api integration
Summary: [OSP-director] nova ec2-api integration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z3
: 11.0 (Ocata)
Assignee: Sven Anderson
QA Contact: awaugama
URL:
Whiteboard:
: 1217093 (view as bug list)
Depends On: 1189543
Blocks: 743661 1336839 1438308
TreeView+ depends on / blocked
 
Reported: 2016-05-31 12:08 UTC by Stephen Gordon
Modified: 2019-09-09 14:45 UTC (History)
30 users (show)

Fixed In Version: puppet-tripleo-6.5.0-1.el7ost openstack-tripleo-heat-templates-6.1.0-1.el7ost openstack-ec2-api-4.0.0-3.el7ost
Doc Type: Bug Fix
Doc Text:
The EC2 API was not fully operational. This was because EC2 API support depended on the Glance V1 API, but the Glance V1 API was no longer supported. This fix provides EC2 API support for newer versions of the Glance API.
Clone Of:
Environment:
Last Closed: 2017-10-31 17:37:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1676491 0 None None None 2017-03-28 14:57:12 UTC
OpenStack gerrit 450294 0 None MERGED Add missing include of ::ec2api::keystone::authtoken 2020-11-04 04:16:34 UTC
OpenStack gerrit 450434 0 None MERGED Add missing ec2api::api::keystone_ec2_tokens_url config 2020-11-04 04:16:35 UTC
OpenStack gerrit 458044 0 None MERGED use glanceclient version '2'. fix keystone error message. 2020-11-04 04:16:35 UTC
OpenStack gerrit 462542 0 None MERGED Add parameter Ec2ApiExternalNetwork for VPCs 2020-11-04 04:16:35 UTC
Red Hat Bugzilla 1449745 0 medium CLOSED Pick up EC2API Upstream changes 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:3098 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 director Bug Fix Advisory 2017-10-31 21:33:28 UTC

Internal Links: 1449745

Description Stephen Gordon 2016-05-31 12:08:22 UTC
Description of problem:

Integrate the new EC2-API service into the out of the box director deployment.

https://trello.com/c/XOKJVNaL/151-osp-director-nova-ec2-api-integration

Version-Release number of selected component (if applicable):

10.0

Comment 2 Stephen Gordon 2016-11-11 21:32:22 UTC
Added "Remove old nova-cert service from packages and deployment (may actually happen automatically since this code was removed from Nova and we never actively deployed it, but confirm)." step to Trello.

Comment 3 Stephen Gordon 2016-11-11 21:48:11 UTC
*** Bug 1217093 has been marked as a duplicate of this bug. ***

Comment 8 Sven Anderson 2017-01-09 15:44:32 UTC
The last two  changes that have to merge for this to finally be finished are:
https://review.openstack.org/#/c/398634
https://review.openstack.org/#/c/336562

They are under final refinements for making them pass the CI.

Comment 10 Lukas Ruzicka 2017-02-09 11:20:43 UTC
Can you provide more info on this bug or a sample DocText, so that we can use it for documentation of OSP 11? Thanks a lot.

Comment 12 Thierry Vignaud 2017-02-14 17:20:19 UTC
Change #398634 from comment #8 is in openstack-tripleo-heat-templates-6.0.0-0.20170130212245.el7ost

Change #336562 from comment #8 is in puppet-tripleo-6.1.0-0.20170128003046.875a9f9.el7ost

BTW I think it would have been better to have a bug per package and to list the changes in "External Trackers"

Comment 25 Dan Macpherson 2017-06-14 02:06:34 UTC
Hi Sven,

Is the EC2 API now compatible with newer versions of the Glance API?

Comment 35 Sven Anderson 2017-06-19 17:54:59 UTC
The RDO imports for Z1 have not been done yet, I will fill in the "Fixed In Version" once this has happened.

Comment 40 Lon Hohberger 2017-09-06 19:58:41 UTC
According to our records, this should be resolved by puppet-tripleo-6.5.0-5.el7ost.  This build is available now.

Comment 41 Lon Hohberger 2017-09-06 19:58:55 UTC
According to our records, this should be resolved by openstack-tripleo-heat-templates-6.1.0-2.el7ost.  This build is available now.

Comment 42 Lon Hohberger 2017-09-06 19:59:05 UTC
According to our records, this should be resolved by openstack-ec2-api-4.0.0-3.el7ost.  This build is available now.

Comment 49 errata-xmlrpc 2017-10-31 17:37:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3098


Note You need to log in before you can comment on or make changes to this bug.