Bug 1341176 - [OSP-director] [RFE] Add real-time compute node role
Summary: [OSP-director] [RFE] Add real-time compute node role
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Sven Anderson
QA Contact: awaugama
URL:
Whiteboard:
: 1412226 (view as bug list)
Depends On: 1271852 1298079 1384845 1411971 1441923 1445709 1468004 1591229 1656068 1656069 1691740
Blocks: 1419948 1442136 1465537 1414569 1414580 1599573
TreeView+ depends on / blocked
 
Reported: 2016-05-31 12:13 UTC by Stephen Gordon
Modified: 2019-09-09 13:19 UTC (History)
32 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180304031146.6cd4184.el7ost
Doc Type: Enhancement
Doc Text:
This enhancement adds support for deploying RT enabled compute nodes from director alongside "regular" compute nodes. 1. Based on tripleo-heat-templates/environments/compute-real-time-example.yaml, create a compute-real-time.yaml environment file that sets the parameters for the ComputeRealTime role with at least the correct values for: * IsolCpusList and NovaVcpuPinSet: a list of CPU cores that should be reserved for real-time workloads. This depends on your CPU hardware on your real-time compute nodes. * KernelArgs: set to "default_hugepagesz=1G hugepagesz=1G hugepages=X" with X depending on the number of guests and how much memory they will have. 2. Build and upload the overcloud-realtime-compute image: * Prepare the repos (for CentOS): - sudo yum install -y https://trunk.rdoproject.org/centos7/current/python2-tripleo-repos-XXX.el7.centos.noarch.rpm - sudo -E tripleo-repos current-tripleo-dev - export DIB_YUM_REPO_CONF="/etc/yum.repos.d/delorean* /etc/yum.repos.d/quickstart*" * openstack overcloud image build --image-name overcloud-realtime-compute --config-file /usr/share/openstack-tripleo-common/image-yaml/overcloud-realtime-compute.yaml --config-file /usr/share/openstack-tripleo-common/image-yaml/overcloud-realtime-compute-centos7.yaml * openstack overcloud image upload --update-existing --os-image-name overcloud-realtime-compute.qcow2 3. Create roles_data.yaml with ComputeRealTime and all other required roles, for example: `openstack overcloud roles generate -o ~/rt_roles_data.yaml Controller ComputeRealTime ...` and assign the ComputeRealTime role to the real-time nodes in one of the usual ways. See https://docs.openstack.org/tripleo-docs/latest/install/advanced_deployment/custom_roles.html 4. Deploy the overcloud: openstack overcloud deploy --templates -r ~/rt_roles_data.yaml -e ./tripleo-heat-templates/environments/host-config-and-reboot.yaml -e ./compute-real-time.yaml [...]
Clone Of:
: 1414580 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:26:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 529381 None MERGED Do not filter packages from RT repo 2020-09-01 10:55:53 UTC
OpenStack gerrit 531442 None MERGED Add realtime-kernel element 2020-09-01 10:55:52 UTC
OpenStack gerrit 531446 None MERGED Add new image for realtime computes 2020-09-01 10:55:52 UTC
OpenStack gerrit 531739 None MERGED Add custom role for realtime compute 2020-09-01 10:55:52 UTC
OpenStack gerrit 532465 None MERGED Allow defaults for Image/Flavor/RoleParameters in roles_data.yaml 2020-09-01 10:55:52 UTC
OpenStack gerrit 533634 None MERGED Replace hardcoded profile name with _TUNED_PROFILE_NAME_ 2020-09-01 10:55:52 UTC
OpenStack gerrit 535428 None MERGED Make sure, the realtime element removes the default kernel 2020-09-01 10:55:52 UTC
Red Hat Product Errata RHEA-2018:2086 normal SHIPPED_LIVE Red Hat OpenStack Platform 13.0 Enhancement Advisory 2018-06-28 19:51:39 UTC

Description Stephen Gordon 2016-05-31 12:13:40 UTC
Description of problem:

Add support for deploying RT enabled compute nodes from director alongside "regular" compute nodes.

https://trello.com/c/Ts9ftFbH

Version-Release number of selected component (if applicable):

10.0

Comment 7 Eoghan Glynn 2017-01-13 08:27:29 UTC
*** Bug 1412226 has been marked as a duplicate of this bug. ***

Comment 9 Stephen Gordon 2017-06-15 17:27:30 UTC
Moving to Queens, as while progress is being made there is ongoing outstanding work required.

Comment 16 Sven Anderson 2018-01-29 13:45:55 UTC
All changes merged before M3. Moving to POST.

Comment 31 Yolanda Robla 2018-04-10 12:14:53 UTC
So from my understanding, this is a similar topic than the one for security hardened images. While we don't support image creation with DIB, we are supporting the image creation based on DIB, but with the code in tripleo-common. As it was a procedure that can be documented and tested, it was accepted.

Ollie already provided the yaml files to compose the images in tripleo-common, so i think that the best way to compose those images is use that yaml file and use the openstack overcloud build command

https://github.com/openstack/tripleo-common/blob/master/image-yaml/overcloud-realtime-compute.yaml

Comment 37 errata-xmlrpc 2018-06-27 13:26:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.