Bug 134126 - Evolution crash when using toolbar
Evolution crash when using toolbar
Status: CLOSED DUPLICATE of bug 133969
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 14:43 EDT by Jerome Lambert
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerome Lambert 2004-09-29 14:43:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040928

Description of problem:
Evolution crash when i click on tools such as calendar or tasks.

Version-Release number of selected component (if applicable):
evolution-2.0.0-2

How reproducible:
Sometimes

Steps to Reproduce:
1. Start evolution
2. click on Adress Book
3.
    

Actual Results:  Evolution crash

Expected Results:  Viewing adress book ;-)

Additional info:

Here is the output when launched in a shell:
asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'

(evolution:10167): Bonobo-WARNING **: Non-toolbar parent '<NULL-instance>'

(evolution:10167): Bonobo-CRITICAL **: file
bonobo-ui-toolbar-control-item.c: line 107
(impl_toolbar_reconfigured): assertion `toolbar != NULL' failed

(evolution:10167): GLib-GObject-CRITICAL **: file gobject.c: line 1597
(g_object_get_qdata): assertion `G_IS_OBJECT (object)' failed

(evolution:10167): GLib-GObject-CRITICAL **: file gobject.c: line 1597
(g_object_get_qdata): assertion `G_IS_OBJECT (object)' failed

(evolution:10167): GLib-GObject-CRITICAL **: file gobject.c: line 1597
(g_object_get_qdata): assertion `G_IS_OBJECT (object)' failed

(evolution:10167): GLib-GObject-CRITICAL **: file gobject.c: line 1597
(g_object_get_qdata): assertion `G_IS_OBJECT (object)' failed

(evolution:10167): Gtk-WARNING **: A floating object was finalized.
This means that someone
called g_object_unref() on an object that had only a floating
reference; the initial floating reference is not owned by anyone
and must be removed with gtk_object_sink() after a normal
reference is obtained with g_object_ref().
Comment 1 Dave Malcolm 2004-09-29 14:45:37 EDT
Thanks for the report; this is a bug in the latest version of
libbonoboui and we're working on a fix.
Comment 2 Michael Wiktowy 2004-09-29 20:36:28 EDT
This is a problem for me too.
For additional info:

Trying to access those views from the menu instead:
   causes crash also with the exact same console output.

Trying to by-pass toolbar/menu and starting up other windows via
console results in:
[~]$ evolution -contacts
asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'

(evolution:3460): evolution-shell-WARNING **: Unknown component ontacts

.... yup ... it says "ontacts" ... some parsing truncation happening
somewhere?

Same thing happens for calendar:
[~]$ evolution -calendar
asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'

(evolution:3482): evolution-shell-WARNING **: Unknown component alendar
Comment 3 Nigel Metheringham 2004-09-30 06:07:09 EDT
Further to Dave Malcolm's comment #1

I am seeing this too (evolution-2.0.1-2,
libbonoboui-2.8.0.99cvs20040927-1).

Reverting down to libbonoboui-2.8.0-1 (yay for yum's package cache)
fixes the problem for me.

[NB if you haven't done this before, you need to add --oldpackage to
your rpm command to do this:-
  rpm -Uvh --oldpackage \
   /var/cache/yum/development/packages/libbonoboui-2.8.0-1.i386.rpm \
   /var/cache/yum/development/packages/libbonoboui-devel-2.8.0-1.i386.rpm

]
Comment 4 Dave Malcolm 2004-09-30 10:38:27 EDT
libbonoboui-2.8.0.99cvs20040929-1 or later should fix this

*** This bug has been marked as a duplicate of 133969 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:06:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.