This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 134207 - package dependencies seem to tie themselves in a knot
package dependencies seem to tie themselves in a knot
Status: CLOSED DUPLICATE of bug 134130
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 02:57 EDT by Michal Jaegermann
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-09-30 02:57:55 EDT
Description of problem:

Something went really funny with package dependencies in
an updates set 'rpmdb-fedora-2.91-0.20040929'.  It looks
to me that the problem is not in yum but in rpm libraries.

After failed attempts to use yum I tried directly 'rpm -Fvh ...'
with a bunch of packages from that update set and ended up with:

error: Failed dependencies:
        linc >= 0.1.6 is needed by (installed) pyorbit-2.0.0-3.1
        linc = 1.0.3 is needed by (installed) linc-devel-1.0.3-6

while 'rpm -q linc' responds with 'linc-1.0.3-6' and
'rpm -q linc-devel' with 'linc-devel-1.0.3-6'.  The error appears
to trip yum.

It seems that the real culprit is ORBit2, though, but why it
triggers this problem is far from clear to me.  Still, when other
packages are got updated then ORBit2, and ORBit2-devel, could be 
updated as well but only then.

Originally yum was unhappy both with 2.1.3-1 version and also
after an update to yum-2.1.4-1; but as I said, this does not
look really as a yum fault.  I also tried that on a local repository
generated with 'createrepo' on a directory with copies of all
needed rpms.  Regardless if 'linc' packages were present or not
during a createrepo run results were exactly the same - i.e. yum
was bailing out complaining about needed 'linc'.
Comment 1 Bill Nottingham 2004-09-30 09:25:12 EDT

*** This bug has been marked as a duplicate of 134130 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.