Bug 134219 - crashes on close
crashes on close
Status: CLOSED DUPLICATE of bug 133969
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-30 06:04 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-09-30 06:04:30 EDT
Description of problem:
gthumb crashes every time I close it.

Version-Release number of selected component (if applicable):
2.4.2-1

How reproducible:
100%

Steps to Reproduce:
1. Start gthumb
2. Close it
  
Actual results:
Backtrace was generated from '/usr/bin/gthumb'

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -151142272 (LWP 15829)]
[New Thread 146529200 (LWP 15836)]
[Thread debugging using libthread_db enabled]
[New Thread -151142272 (LWP 15829)]
[New Thread 146529200 (LWP 15836)]
[Thread debugging using libthread_db enabled]
[New Thread -151142272 (LWP 15829)]
[New Thread 146529200 (LWP 15836)]
[New Thread 46128048 (LWP 15835)]
[New Thread 35638192 (LWP 15834)]
[New Thread 73640880 (LWP 15833)]
[New Thread 58493872 (LWP 15832)]
[New Thread 126978992 (LWP 15831)]
[New Thread 25148336 (LWP 15830)]
0x00112782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x00112782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x003733eb in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x06809f50 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00520a4d in g_type_check_instance_is_a (type_instance=0x616d692d, 
    iface_type=20) at gtype.c:3126
#5  0x00506a73 in g_object_get_qdata (object=0x99619e8, quark=180)
    at gobject.c:1597
#6  0x00887c93 in gtk_widget_set_state () from
/usr/lib/libgtk-x11-2.0.so.0
#7  0x00888862 in gtk_widget_set_uposition () from
/usr/lib/libgtk-x11-2.0.so.0
#8  0x0083ae4b in gtk_tool_item_get_type () from
/usr/lib/libgtk-x11-2.0.so.0
#9  0x00839a02 in gtk_tool_button_get_type () from
/usr/lib/libgtk-x11-2.0.so.0
#10 0x06595895 in bonobo_ui_toolbar_control_item_get_type ()
   from /usr/lib/libbonoboui-2.so.0
#11 0x005028dc in g_object_unref (_object=0x9307b8) at gobject.c:570
#12 0x00502a17 in g_object_run_dispose (object=0x99619e8) at gobject.c:603
#13 0x007abe18 in gtk_object_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x008813b3 in gtk_widget_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x00833e3b in gtk_toolbar_get_n_items () from
/usr/lib/libgtk-x11-2.0.so.0
#16 0x0070ffcb in gtk_container_foreach () from
/usr/lib/libgtk-x11-2.0.so.0
#17 0x007122e8 in gtk_container_unset_focus_chain ()
   from /usr/lib/libgtk-x11-2.0.so.0
#18 0x005180ae in g_cclosure_marshal_VOID__VOID (closure=0x531a5c, 
    return_value=0x0, n_param_values=1, param_values=0x616d692d, 
    invocation_hint=0xfee03eb8, marshal_data=0x7122ac) at gmarshal.c:77
#19 0x005006b2 in g_type_class_meta_marshal (closure=0x97a45b8, 
    return_value=0x616d692d, n_param_values=1634560301, 
    param_values=0xfee03fe0, invocation_hint=0x616d692d, 
    marshal_data=0x616d692d) at gclosure.c:514
#20 0x00500347 in g_closure_invoke (closure=0x97a45b8, 
    return_value=0x616d692d, n_param_values=1634560301, 
    param_values=0x616d692d, invocation_hint=0x616d692d) at gclosure.c:437
#21 0x00515b9d in signal_emit_unlocked_R (node=0x97a45f0, detail=0, 
    instance=0x9863b58, emission_return=0x0,
instance_and_params=0xfee03fe0)
    at gsignal.c:2551
#22 0x005179bc in g_signal_emit_valist (instance=0x9863b58, signal_id=1, 
    detail=0, var_args=0xfee0416c "G¾z") at gsignal.c:2194
#23 0x00517c5a in g_signal_emit (instance=0x616d692d,
signal_id=1634560301, 
    detail=1634560301) at gsignal.c:2238
#24 0x007abe8d in gtk_object_destroy () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x00887417 in gtk_widget_get_default_direction ()
   from /usr/lib/libgtk-x11-2.0.so.0
#26 0x09863b58 in ?? ()
#27 0x00000001 in ?? ()
#28 0x008873eb in gtk_widget_get_default_direction ()
   from /usr/lib/libgtk-x11-2.0.so.0
#29 0x09863b58 in ?? ()
#30 0xfee041c8 in ?? ()
#31 0x00502a0f in g_object_run_dispose (object=0x9863b58) at gobject.c:602
Comment 1 Jonathan Blandford 2004-09-30 10:50:01 EDT

*** This bug has been marked as a duplicate of 133969 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.