Bug 1342224 - Openstack cloud provider not disabled Timelines subbutton when no events available
Summary: Openstack cloud provider not disabled Timelines subbutton when no events avai...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: GA
: 5.7.0
Assignee: Harpreet Kataria
QA Contact: Ievgen Zapolskyi
URL:
Whiteboard: ui:openstack
Depends On:
Blocks: 1353234
TreeView+ depends on / blocked
 
Reported: 2016-06-02 17:08 UTC by Matouš Mojžíš
Modified: 2020-04-14 03:56 UTC (History)
7 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1353234 (view as bug list)
Environment:
Last Closed: 2016-10-12 15:41:15 UTC
Category: ---
Cloudforms Team: Unknown
Target Upstream Version:
izapolsk: needinfo-


Attachments (Terms of Use)

Description Matouš Mojžíš 2016-06-02 17:08:08 UTC
Description of problem:
When no event processor like ceilometer or AMQP is configured or configured badly, then I am still able to go to timelines. In provider summary there is timelines disabled in properties, but not disabled in Monitoring select button.
I think it should be unified and not disabled in both or disabled in both.

Version-Release number of selected component (if applicable):
5.6.0.9

How reproducible:
Always

Steps to Reproduce:
1. Add openstack cloud provider without configuring event processor.
2. Go to provider summary page
3.

Actual results:
Monitoring subbutton timelines is clickable and lets me go to timelines page, whilst properties timelines link is gray and unclickable.

Expected results:
Monitoring subbuton timelines should be gray and unclickable or properties timelines link should be clickable.

Additional info:

Comment 3 CFME Bot 2016-06-15 21:45:52 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d49a91bff7149af08d3202e7830887d025569dba

commit d49a91bff7149af08d3202e7830887d025569dba
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jun 2 15:35:20 2016 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jun 13 14:50:00 2016 -0400

    Disable timelines button when no timeline data is available for provider
    
    - Also hide Monitoring button group when there are no buttons under it.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1342224
    https://bugzilla.redhat.com/show_bug.cgi?id=1342217

 .../application_helper/button/ems_cloud_timeline.rb       |  5 -----
 .../application_helper/button/ems_infra_timeline.rb       |  5 -----
 app/helpers/application_helper/button/ems_timeline.rb     | 15 +++++++++++++++
 .../application_helper/toolbar/ems_cloud_center.rb        |  2 +-
 .../application_helper/toolbar/ems_infra_center.rb        |  2 +-
 5 files changed, 17 insertions(+), 12 deletions(-)
 delete mode 100644 app/helpers/application_helper/button/ems_cloud_timeline.rb
 delete mode 100644 app/helpers/application_helper/button/ems_infra_timeline.rb
 create mode 100644 app/helpers/application_helper/button/ems_timeline.rb

Comment 4 CFME Bot 2016-06-15 21:46:00 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/db708d9ca35bb67a90a259cc3312e1467fb3aca2

commit db708d9ca35bb67a90a259cc3312e1467fb3aca2
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jun 2 16:56:49 2016 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jun 13 14:59:59 2016 -0400

    Added spec tests to verify fix.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1342224
    https://bugzilla.redhat.com/show_bug.cgi?id=1342217

 .../application_helper/buttons/ems_timeline.rb     | 39 ++++++++++++++++++++++
 .../application_helper/toolbar_builder_spec.rb     | 15 +++++++++
 2 files changed, 54 insertions(+)
 create mode 100644 spec/helpers/application_helper/buttons/ems_timeline.rb

Comment 7 Ievgen Zapolskyi 2016-10-03 11:49:02 UTC
I've just checked this issue in 5.7.0.3.
1. Monitoring menu is not grayed out though Timelines is dimmed for OpenStack now.
2. Timelines is still available for Azure when there is no any timelines events yet.

Comment 8 Harpreet Kataria 2016-10-03 22:22:49 UTC
Ievgen,

Have you checked if there are Policy Timelines events available for the provider in question. If not can you provide access to your appliance i can take a look at it. Let me know.

Thanks.
~Harpreet

Comment 9 Ievgen Zapolskyi 2016-10-05 15:30:23 UTC
Harpreet,
I already destroyed that appliance.
I've just deployed new one.
Timelines is grayed out for both Azure and RHOS providers this time but Monitoring menu is still available.
You can access this appliance using ip 10.8.199.248.

Comment 10 Harpreet Kataria 2016-10-12 15:41:15 UTC
Levgen,

I am closing this BZ as not a bug as Timelines button is disabled/grayed when no timeline data is available. We show "Monitoring" menu with disabled buttons under it in other parts of UI when button under the groups are disabled so this is not a bug.

Thanks,
~Harpreet


Note You need to log in before you can comment on or make changes to this bug.