Bug 1342350 - Volume set option not present to enable leases
Summary: Volume set option not present to enable leases
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Poornima G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.8.0
TreeView+ depends on / blocked
 
Reported: 2016-06-03 05:02 UTC by Poornima G
Modified: 2016-06-16 12:33 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 12:33:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2016-06-03 05:02:03 UTC
Description of problem:
Volume set option not present to enable leases

Version-Release number of selected component (if applicable):
3.8

How reproducible:
There is no volume set option, currently to enable one should edit the volfile

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-06-03 05:03:28 UTC
REVIEW: http://review.gluster.org/14626 (glusterd: volgen and volume set changes for leases) posted (#1) for review on release-3.8 by Poornima G (pgurusid@redhat.com)

Comment 2 Vijay Bellur 2016-06-13 10:26:07 UTC
REVIEW: http://review.gluster.org/14626 (glusterd: volgen and volume set changes for leases) posted (#2) for review on release-3.8 by Poornima G (pgurusid@redhat.com)

Comment 3 Vijay Bellur 2016-06-13 11:23:17 UTC
COMMIT: http://review.gluster.org/14626 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 02d3f5e68be6adb42359eb03de4801b27dc2a12e
Author: Poornima G <pgurusid@redhat.com>
Date:   Mon Jul 20 16:44:32 2015 +0530

    glusterd: volgen and volume set changes for leases
    
    Add leases xlator in volgen and also add corresponding volume set options
    
    Backport of http://review.gluster.org/#/c/11722
    
    Cherry picked from commit bc525b01002d7649be0ac28c5761c8ce92b6a658:
    > Change-Id: Ic5de50cdb87eaf6a833e739bc7e08fecbeca3de3
    > BUG: 1319992
    > Signed-off-by: Poornima G <pgurusid@redhat.com>
    > Reviewed-on: http://review.gluster.org/11722
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: Ic5de50cdb87eaf6a833e739bc7e08fecbeca3de3
    BUG: 1342350
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/14626
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Niels de Vos 2016-06-16 12:33:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.