Bug 134265 - Machine hang on X logout
Machine hang on X logout
Status: CLOSED DUPLICATE of bug 138822
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
David Lawrence
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-09-30 14:20 EDT by Jon Orris
Modified: 2014-06-18 05:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X Config file (2.74 KB, text/plain)
2004-09-30 14:21 EDT, Jon Orris
no flags Details
X log (45.69 KB, text/plain)
2004-10-14 18:08 EDT, Jon Orris
no flags Details

  None (edit)
Description Jon Orris 2004-09-30 14:20:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
Whenever I log out of an X session, the machine hangs completely. All
ssh connections die, there is no keyboard or ping response. The
monitor blanks with a warning that the signal is out of it's
acceptable range.

Running xorg-x11-6.8.1-4 from rawhide nightly updated 9/30/04.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-4

How reproducible:
Always

Steps to Reproduce:
1. Login to Gnome
2. log out
3. Boom
    

Additional info:
Comment 1 Jon Orris 2004-09-30 14:21:15 EDT
Created attachment 104596 [details]
X Config file
Comment 2 Jon Orris 2004-09-30 17:35:20 EDT
This does not occur if I do CTRL-ALT-BKSPC to exit X.

Comment 4 Mike A. Harris 2004-10-07 05:40:51 EDT
Please attach the X server log file from a failed server startup.
Comment 5 Mike A. Harris 2004-10-12 15:30:13 EDT
ping
Comment 6 Jon Orris 2004-10-14 18:08:26 EDT
Created attachment 105246 [details]
X log

X log from when machine locks up. From tailing the logs before it locked out,
nothing has been entered after I logged out of the gnome session.
Comment 7 Søren Sandmann Pedersen 2004-10-18 13:03:36 EDT
The problem disappears when DRI is disabled. Disabling rhgb does not
have an effect
Comment 8 Søren Sandmann Pedersen 2004-11-08 10:56:50 EST
This problem does not appear under gdb either, and is un-reproducable
on a machine with a similar card.

Re-targeting for FC4.
Comment 9 Sharky 2004-11-25 13:14:43 EST
This problem occurs for me, too, and it is exactly as Jon describes. 
If you tell me which files you'd like, I'm happy to provide them.
Comment 10 Søren Sandmann Pedersen 2004-12-02 09:01:29 EST
The result of "lspci -v" run as root could be useful. Also, your
/var/log/messages file. 
Comment 11 Søren Sandmann Pedersen 2004-12-13 18:33:15 EST
Could one of you please check if the latest rawhide version of X still
produces this when 'load "dri"' is present in xorg.conf?

I suspect this is a duplicate of bug 138822.
Comment 12 Kristian Høgsberg 2005-01-12 15:31:06 EST
This looks like it is caused by a bug in 4g4g kernel patch that was
recently resolved.  Could you please try to upgrade your kernel to the
latest FC3 update kernel (2.6.10-1.737 as of this writing) and see if
the problem persists.

Thanks.
Comment 13 Søren Sandmann Pedersen 2005-03-01 11:59:26 EST
Marking duplicate of 138822, please reopen if any of you still see the
problem.

*** This bug has been marked as a duplicate of 138822 ***
Comment 14 Red Hat Bugzilla 2006-02-21 14:06:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.