Bug 138822 - [PATCH] System freezes after logout (Rage 128)
[PATCH] System freezes after logout (Rage 128)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 132930 134265 140708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 08:24 EST by Alar Suija
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 16:21:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg-x11-6.8.1-r128-logout-deadlock.patch (363 bytes, patch)
2004-11-16 19:58 EST, Warren Togami
no flags Details | Diff

  None (edit)
Description Alar Suija 2004-11-11 08:24:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
System freezes hard (display turns off, no disk activity, no ping
answer, soft power button no func.) during log- out (standard
workstation install, GNOME,  all updates installed). If i select
"reboot" or "shutdown" (e.g. X do not restart after session's end)
then everything is O.K.

Replacing card with Matrox G200 solved problem for me.

Card data: Rage 128 Pro/Xpert2000 Pro 32MB 


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667 xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. Actions -> Log Out -> Log out
2. System freezes
3.
    

Additional info:
Comment 1 Alar Suija 2004-11-11 13:41:18 EST
hwconf info:

....
driver: Card:ATI Rage 128
desc: "ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS"
vendorId: 1002
deviceId: 5046
subVendorId: 1002
subDeviceId: 0008
....

lspci output (with Matrox as replacement)

00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 02)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 02)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:0a.0 SCSI storage controller: Adaptec AHA-7850 (rev 03)
00:0c.0 Multimedia audio controller: Yamaha Corporation YMF-724 (rev 05)
00:0d.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 0c)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP
(rev 01)

Comment 2 Daniel P. Stasinski 2004-11-11 21:41:31 EST
I was able to fix this by removing "Load DRI" from xorg.conf
Comment 3 Warren Togami 2004-11-16 01:51:08 EST
I ran into an affected R128 card today with exactly this behavior. 
daniels in #freedesktop mentioned that this should fix this issue.  I
am doing test builds and testing it tomorrow.

cat xorg-x11-6.8.1-r128-logout-deadlock.patch
--- xc/programs/Xserver/hw/xfree86/drivers/ati/r128_dri.c.orig 
2004-11-15 20:36:38.862313439 -1000
+++ xc/programs/Xserver/hw/xfree86/drivers/ati/r128_dri.c      
2004-11-15 20:44:06.322211487 -1000
@@ -1297,6 +1297,7 @@
     if (info->irq) {
        drmCtlUninstHandler(info->drmFD);
        info->irq = 0;
+       save->gen_int_cntl = 0;
     }

                                /* De-allocate vertex buffers */
Comment 4 Warren Togami 2004-11-16 02:12:08 EST
Crap, that should be info-> rather than save->
Comment 5 Juan Antonio Martinez 2004-11-16 13:31:45 EST
hey! i had same problem. Seems that ATI r128 driver doesn't support
Acceleration in 24 bpp mode.

Just selection of 16 bpp depth solves the problem. now my ATI Rage 
Xpert works fine with acceleration

No need to disable accel, nor dri load, nor RestartServer in xdm.conf.
Comment 6 Alar Suija 2004-11-16 13:42:43 EST
it's not so simple, i used 16 bpp.
Comment 7 Warren Togami 2004-11-16 16:21:05 EST
http://people.redhat.com/wtogami/temp/xorg/
FC3 users, please test the xorg-x11 packages here.  I added the
one-liner patch to the r128 driver.
Comment 8 Warren Togami 2004-11-16 19:58:45 EST
Created attachment 106862 [details]
xorg-x11-6.8.1-r128-logout-deadlock.patch

Patch tested earlier today, seems to work great.
Comment 9 Adam Foran 2004-11-17 22:07:13 EST
I had the same problem (lock-up on logout with a ATI Rage 128 card).
I tested the RPMS Warren provided above and this fixed the issue
for me.

Thanks.
Comment 10 Deji 2004-11-18 01:16:38 EST
Warren's RPMs solves same problem for me too.

Thanks.
Comment 11 Alar Suija 2004-11-18 06:41:24 EST
Warren's RPMs works for me too. Great job, thanks!
Comment 12 Féliciano Matias 2004-11-18 15:01:51 EST
From /etc/sysconfig/hwconf
bus: PCI
detached: 0
driver: Card:ATI Mach64 3D Rage IIC
desc: "ATI Technologies Inc 3D Rage IIC AGP"
vendorId: 1002
deviceId: 475a
subVendorId: 1002
subDeviceId: 0084

4MB.

No problem with 6.8.1-12, no problem with 6.8.1-12.r128.
So, no regression.
Comment 13 Mike A. Harris 2004-11-18 15:13:34 EST
Replying to comment #12:

The card you are using is an ATI Mach64 card, however this
bug and the fix for it, are for the Rage 128 based boards,
using the "r128" driver.  Your card uses the "atimisc" driver
which gets called from the "ati" driver wrapper.  Unfortunately,
using a Mach64 card does not test this driver for regression,
but thanks for trying it out and reporting anyway!
Comment 14 Alar Suija 2004-11-19 03:19:12 EST
By the way, seems, that #129924 is real bug in FC3 (with generated
xorg config), at least it is very reproducible and caused by
xscreensaver. What is funny- after next xscreensaver run cursor turns
O.K. and so on and so on...  :)
Comment 15 Warren Togami 2004-11-22 05:34:58 EST
Bug #129924 is clearly an entirely different issue.  Please do not
confuse matters by adding off-topic comments like this.
Comment 16 Mike A. Harris 2004-11-23 16:14:06 EST
Is there an upstream freedesktop.org bug for this issue also?
Just like to know so I can document it inside the patch, and
so we don't duplicate effort later on.

Patch will be in the next FC3 update, and in rawhide soon.

Thanks.
Comment 17 Mike A. Harris 2004-11-23 16:21:13 EST
Patch checked into CVS in rawhide.  Setting status to "RAWHIDE".
The new rpms will be available in rawhide within the next
3-5 days.  The next FC3 erratum will include this also (no
timeline).
Comment 18 Warren Togami 2004-11-23 16:26:50 EST
https://bugs.freedesktop.org/show_bug.cgi?id=1886
Comment 19 Matt Britt 2004-11-24 14:56:36 EST
I have the exact same problem, but with the radeon display module. 
Currently using the latest xorg-x11 RPMs.
Comment 20 Mike A. Harris 2004-11-24 15:01:52 EST
In reply to comment #19:

This was a Rage 128 driver specific problem, so your problem is
not exactly the same, as you're using the "radeon" driver.  Your
problem might have similar symptoms, but it is an entirely
different problem.  There are already similar problems reported
in bugzilla against the radeon driver if you'd like to CC yourself
on them though.
Comment 21 Sitsofe Wheeler 2004-12-04 15:58:40 EST
I'm not so sure that this has been fixed.

I only noticed this bug on the test list today and given I've been
having a few problems with this card I figured I'd test out the new
packages. I was somewhat lazy and only installed the minimum I could
which was:
xorg-x11-6.8.1-12.r128.i386.rpm
xorg-x11-libs-6.8.1-12.r128.i386.rpm
xorg-x11-xfs-6.8.1-12.r128.i386.rpm

Hopefully that won't invalidate my results. I also ran a full prelink
after installing the above to rule it out as a factor.

My test was to restart X using ctrl-alt-backspace. With DRI enabled
this would result in an instant freeze. Basically after lots and lots
of crashes I found that things appeared to work providing a resolution
of 1024x768 or less was chosen. However, if I log in and do something
like play bzflag then logout then I get a freeze even on 1024x768. I
could reproduce the freeze straight away with a resolution of
1600x1200 so I'm thinking that perhaps the amount of corruption taking
place has been lessened but not eliminated...

lspci:
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 RF/SG AGP
hwconf:
class: VIDEO
bus: PCI
detached: 0
driver: Card:ATI Rage 128
desc: "ATI Technologies Inc Rage 128 RF/SG AGP"
vendorId: 1002
deviceId: 5246
subVendorId: 1002
subDeviceId: 0008
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0

According to X it's a 16Mbyte card.

(PS do any other r128 owners suffer lockups with/without DRI when
switching to a virtual terminal after an X restart? If so please add
useful comments to bug #140253 )
Comment 22 Bill Shannon 2004-12-16 14:03:42 EST
*** Bug 132930 has been marked as a duplicate of this bug. ***
Comment 23 Alan Cox 2005-01-02 10:45:42 EST
*** Bug 140708 has been marked as a duplicate of this bug. ***
Comment 24 Michael George 2005-01-02 14:51:10 EST
I tried the updated rpm's given above, but am still experiencing the
crash. Please let me know if there's any additional information I can
provide to help troubleshoot the problem.
Comment 25 Sitsofe Wheeler 2005-01-04 18:58:56 EST
Re: #21
My problem went away after upgrading to the 2.6.9-1.724_FC3 kernel
Comment 26 Michael George 2005-01-05 11:03:39 EST
Mine also went away after upgrading to the 2.6.9-1.724_FC3 kernel
(note that I had previously installed the above RPM's and they did not
work for me.)
Comment 27 Søren Sandmann Pedersen 2005-03-01 11:59:40 EST
*** Bug 134265 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.