Bug 1343050 - cluster create wizard - first page - differences between design document and implementation
Summary: cluster create wizard - first page - differences between design document and ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-06 12:12 UTC by Martin Kudlej
Modified: 2016-08-23 19:54 UTC (History)
5 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:54:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
create cluster - 1st step design (396.84 KB, image/png)
2016-06-07 18:17 UTC, Ju Lim
no flags Details
create cluster - 1st step implementation (156.41 KB, image/png)
2016-06-07 18:18 UTC, Ju Lim
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-06-06 12:12:51 UTC
Description of problem:
There are these differences between design document and current implementation at first page of cluster creation wizard:
1) design document: "Clicking on the Info link will pop-up more information about auto-expansion."
There is no link like this in UI.

2) Missing in UI "Clicking on the Info link will pop-up more information about auto-expansion."

3) Missing in UI "Clicking on the Info link will pop-up more information about auto-expansion."

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-19.el7scon.noarch
ceph-installer-1.0.11-1.el7scon.noarch
rhscon-ceph-0.0.20-1.el7scon.x86_64
rhscon-core-0.0.21-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. start cluster creation wizard and compare design document with implementation

Actual results:
Some items are not implemented and info link is missing.

Expected results:
Missing items will be implemented or there will be explanation why they will not be implemented.

Comment 1 Ju Lim 2016-06-07 18:17:21 UTC
Created attachment 1165729 [details]
create cluster - 1st step design

Comment 2 Ju Lim 2016-06-07 18:18:18 UTC
Created attachment 1165730 [details]
create cluster - 1st step implementation

Comment 3 Ju Lim 2016-06-07 18:24:14 UTC
Per design, there are 4 parameters shown: cluster name, journal size, replicas (count), and selinux mode.  For 1.0, the requirements (agreed with PM) would be cluster name and journal size.  Replicas and selinux mode not needed to be shown for 1.0.

The "i" link/icon appears to be the wrong icon (it's an exclamation mark, which should not be used) in the beginning vs. at the end of the text -- per design, it's supposed to be at the end of the text block.  For the "i" (information bubble/tooltip) is in the design, and should provide some details about the auto-expansion.  If no plans to provide it, remove the "i" link.

Suggested priority is low.

Comment 4 :Deb 2016-06-15 14:16:37 UTC
Without defining what the "more information" is exactly, it's unrealistic to try implementing the pop-up info.

So, as I see it in current implementation, the text itself works as info text - by putting the info icon in the front.

Also, I don't think this should a blocker for feature freeze or GA. Requesting Sharmilla to think about it.

Comment 5 Ju Lim 2016-06-20 20:34:31 UTC
I don't think the pop-up info is needed as the text should suffice (once the grammar and sentence run-on is fixed) -- there's another bug already filed for this.

Comment 7 Nishanth Thomas 2016-07-09 13:13:42 UTC
As Ju mentioned the bug -> https://bugzilla.redhat.com/show_bug.cgi?id=1328824 <-
is fixed hence moving this bug to ON_QA. None of the other issues mentioned in the bz are not required and won't be fixed

Comment 9 Martin Kudlej 2016-07-15 06:55:45 UTC
Tested with
ceph-ansible-1.0.5-25.el7scon.noarch
ceph-installer-1.0.12-4.el7scon.noarch
rhscon-ceph-0.0.32-1.el7scon.x86_64
rhscon-core-0.0.33-1.el7scon.x86_64
rhscon-core-selinux-0.0.33-1.el7scon.noarch
rhscon-ui-0.0.47-1.el7scon.noarch
and it works.

Comment 11 errata-xmlrpc 2016-08-23 19:54:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.