Bug 134335 - s-c-sc should use "aplay -D -Dplughw:..."
s-c-sc should use "aplay -D -Dplughw:..."
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
: FutureFeature
: 149721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 10:32 EDT by Féliciano Matias
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.11-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 07:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Féliciano Matias 2004-10-01 10:32:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
It's a little improvement but some card (snd-via82xx here) does not
support 44 100 Hz rate.
This is the warning from aplay :
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)

Using "-D plughw:..." should fix this.

Version-Release number of selected component (if applicable):
1.2.10-1

How reproducible:
Always

Steps to Reproduce:
1. launch s-c-sc
2. play test sound

Actual Results:  The sample is not play at accurate rate.

Expected Results:  The sample is play at accurate rate.
Comment 1 Bastien Nocera 2005-04-02 10:08:54 EST
Fixed in CVS.

2005-04-02  Bastien Nocera  <hadess@hadess.net>

        * src/soundcardBackend.py: use plughw: instead of hw: as the device
        to allow resampling for cards that don't support the rate of the
        test file (Closes: #134335)
Comment 2 Bastien Nocera 2005-04-02 12:24:55 EST
*** Bug 149721 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.