Bug 149721 - no sound on Intel 82801DB/DBL/DBM chipset
no sound on Intel 82801DB/DBL/DBM chipset
Status: CLOSED DUPLICATE of bug 134335
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-25 14:07 EST by van
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-02 12:24:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description van 2005-02-25 14:07:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5)
Gecko/20031202 Firebird/0.7

Description of problem:
I run Fedora Core 3 on Gateway Laptop with Intel 82801DB/DBL/DBM sound
chipset. All modules were loaded as listed:

lsmod command gives (shortly for soundcard-related)

Module            Size    Used by
...
snd_intel8x0m     18185   0
snd_intel8x0      34829   0
snd_ac97_codec    64401   2 snd_intel8x0m, snd_intel8x0
snd_pcm_oss       47609   0
snd_mixer_oss     17217   1 snd_pcm_oss
snd_pcm           97993   3 snd_intel8x0m, snd_intel8x, snd_pcm_oss
snd_timer         29765   1 snd_pcm
snd_page_alloc    9673    3 snd_intel8x0m, snd_intel8x0, snd_pcm
gameport          4801    1 snd_intel8x0
snd_mpu401_uart   8769    1 snd_intel8x0
snd_rawmidi       26725   1 snd_mpu401_uart
snd_seq_device    8137    1 snd_raw_midi
snd               54053   10 snd_intel8x0m, snd_intel8x0,
snd_ac97_codec, snd_pcm_oss, snd_mixer_oss, snd_pcm, snd_timer,

          snd_mpu401_uart, snd_rawmidi, snd_seq_device

soundcore         9889    1 snd
...

but system-config-soundcard doesn't produce any sound, and it gives
error message that auto-detection of sound card does not work.

However, on the command terminal, it says this:
van@localhost ~>system-config-soundcard
Simple mixer control 'PCM',0
   Capabilities: pvolume pswitch pswitch-joined
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Front Left: Playback 23 [74%] [on]
   Front Right: Playback 23 [74%] [on]
Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wave' :
Signed 16 bti Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin (-Dplug:hw:0,0)
aplay: pcm_write:1115: write error Input/output error

My modules.conf file is:
alias usb-controller ehci-hcd
alias usb-controller1 usb-uhci
alias ieee1394-controller ohci1394
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/amix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 ||:

#Note: for user under 2.6, changes must also be made to modprobe.conf!
alias eth1 driverloader


I tried CD music too, but there's no sound at all. It seems that all
the modules were already there in their places and everything should
work correctly. I did try to unmute with "aumix", but still no sound
whatsoever.

I did search through the bugzilla but found no similar bug (if it's
actually a bug at all).

I wonder if it has anything to do with the wrong rate, and I don't
know how to change the rate.

Any help is really appreciate!

-van.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have Fedora Core 3 installed (done once)
2. Run system-config-soundcard (everytime)
3. Got no sound, but error message saying that "Automatic detection of
the soundcard did not work. Audio will not be available on the
system..." and the output as shown above.
    

Additional info:
Comment 1 van 2005-02-25 17:27:39 EST
Audio Control in Solaris 10 (running same Gateway laptop - Multiboot)
showed that the sample rate is 48.0kHz too. Does it mean that my
built-in Intel chip only runs with 48.0kHz? How do we change it to
41.0kHz?
Comment 2 Bastien Nocera 2005-04-02 12:24:54 EST

*** This bug has been marked as a duplicate of 134335 ***

Note You need to log in before you can comment on or make changes to this bug.