Bug 134393 - gdm doesn't recognize NIS based user logins
gdm doesn't recognize NIS based user logins
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 19:02 EDT by G.Wolfe Woodbury
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 04:22:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2004-10-01 19:02:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
after firstboot with ypbind running, attempts to login as a NIS/YP
based user results in an unrecognized user.  

Version-Release number of selected component (if applicable):
gdm-2.6.0.5-3

How reproducible:
Always

Steps to Reproduce:
1. fresh install of rawhide from 2004-10-01
2. after firstboot configuration
3. attempt to login as an NIS based username
    

Actual Results:  GDM responds as if the user doesn't exist with the
usual messages in the dialog box.  (e.g. the warning that the username
and password may be wrong)

Expected Results:  normal login

Additional info:

ssh connections to the test machine have no problems with NIS based
users.  Su has no problems with the NIS based usernames.
/var/log/messages shows:

Oct  1 16:02:54 tembo gdm(pam_unix)[3232]: could not identify user
(from getpwnam(ggw))
Oct  1 16:02:54 tembo gdm-binary[3232]: Couldn't set acct. mgmt for ggw

Could this be another glibc bug?
Comment 1 G.Wolfe Woodbury 2004-10-01 19:05:58 EDT
previous glibc bug was bug 133982
Comment 2 The Ha 2004-11-17 12:49:15 EST
Hi
Have anybody find a solution for this ?
I am running the FC3 final and still experience the same problem.
Comment 3 Ray Strode [halfline] 2004-11-17 16:21:31 EST
Hi,

Could you post your /etc/nsswitch.conf file?

Also what does the command

getent passwd 

return?
Comment 4 Ray Strode [halfline] 2004-11-17 16:25:00 EST
Does this only happen the first time you boot after a fresh install or
does this happen every time?
Comment 5 The Ha 2004-11-18 12:07:18 EST
I found the solution for this.

The default of /etc/sysconfig/authconfig is USENIS=no

Change it to "yes" and reboot.
Comment 6 G.Wolfe Woodbury 2004-11-25 20:41:05 EST
Seems to be gone for me.  There were some problems with the FC3 NIS
server as well.

Note You need to log in before you can comment on or make changes to this bug.