Bug 1344212 - Unable to Read the Image Metadata from the Slave Node
Summary: Unable to Read the Image Metadata from the Slave Node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: 3.0
Assignee: Jason Dillaman
QA Contact: Parikshith
Bara Ancincova
URL:
Whiteboard:
: 1421308 (view as bug list)
Depends On:
Blocks: 1322504 1383917 1412948 1494421
TreeView+ depends on / blocked
 
Reported: 2016-06-09 08:02 UTC by Tanay Ganguly
Modified: 2017-12-05 23:29 UTC (History)
6 users (show)

Fixed In Version: RHEL: ceph-12.1.2-1.el7cp Ubuntu: ceph_12.1.2-2redhat1xenial
Doc Type: Bug Fix
Doc Text:
.Mirroring image metadata is supported Image metadata are now replicated to a peer cluster as expected.
Clone Of:
Environment:
Last Closed: 2017-12-05 23:29:38 UTC


Attachments (Terms of Use)
All Features (710 bytes, text/plain)
2016-06-09 08:02 UTC, Tanay Ganguly
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC
Ceph Project Bug Tracker 16212 None None None 2016-06-09 12:19:25 UTC

Description Tanay Ganguly 2016-06-09 08:02:53 UTC
Created attachment 1166194 [details]
All Features

Description of problem:
While reading Image Metadata of an Image from Master Node, i am seeing the Error message

Version-Release number of selected component (if applicable):
rbd-mirror-10.2.1-12.el7cp.x86_64

How reproducible:
Once

Steps to Reproduce:
1. Create an Image without enabling Journal
2. Write some Data on to it.
3. Set Image Metadata on that Image.
for i in `cat features`; do rbd image-meta set RBD/tanay $i 1024 --cluster master; done
 (PFA)
4. Enable Journaling
5. Read the Image Metadata from the Slave Node.
for i in `cat features`; do rbd image-meta get RBD/tanay $i --cluster slave; done

Actual results:
It should show all the Image Metadata values which are already set for that Image from the Slave Node as well


2016-06-09 07:53:02.309938 7fad38cb6d80 20 librbd: metadata_get 0x7fad437f49a0 key=rbd_journal_pool
failed to get metadata rbd_journal_pool of image : (2) No such file or directory
rbd: getting metadata failed: (2) No such file or directory

Expected results:
Its not showing

Additional info:

------------------------------------------------------------------------------

rbd -p RBD ls --cluster slave
2016-06-09 07:55:11.473290 7f5ce3a57d80 20 librbd: list 0x7ffd6c57a040
2016-06-09 07:55:11.474596 7f5ce3a57d80 20 librbd: list_images_v2 0x7ffd6c57a040
tanay



# systemctl status -l ceph-rbd-mirror@slave
● ceph-rbd-mirror@slave.service - Ceph rbd mirror daemon
   Loaded: loaded (/usr/lib/systemd/system/ceph-rbd-mirror@.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2016-06-09 07:45:24 UTC; 9min ago
 Main PID: 14373 (rbd-mirror)
   CGroup: /system.slice/system-ceph\x2drbd\x2dmirror.slice/ceph-rbd-mirror@slave.service
           └─14373 /usr/bin/rbd-mirror -f --cluster slave --id slave --setuser ceph --setgroup ceph

Jun 09 07:45:24 magna003 systemd[1]: Started Ceph rbd mirror daemon.
Jun 09 07:45:24 magna003 systemd[1]: Starting Ceph rbd mirror daemon...
Jun 09 07:52:25 magna003 rbd-mirror[14373]: 2016-06-09 07:52:25.687909 7f549effd700 -1 librbd::object_map::LockRequest: failed to lock object map: (17) File exists



rbd image 'tanay':
        size 102400 kB in 25 objects
        order 22 (4096 kB objects)
        block_name_prefix: rbd_data.38b412200854
        format: 2
        features: layering, exclusive-lock, object-map, fast-diff, deep-flatten, journaling
        flags: 
        journal: 38b412200854
        mirroring state: enabled
        mirroring global id: 7e9ba885-f4d9-4b05-bb59-9fe6b69f6c41
        mirroring primary: false

Comment 2 Jason Dillaman 2016-06-09 11:56:50 UTC
Metadata is not currently replicated and would be a large effort to implement.

Comment 9 Jason Dillaman 2016-09-26 16:29:29 UTC
Upstream, master branch PR: https://github.com/ceph/ceph/pull/11168

Comment 12 Jason Dillaman 2017-02-11 01:04:26 UTC
*** Bug 1421308 has been marked as a duplicate of this bug. ***

Comment 19 errata-xmlrpc 2017-12-05 23:29:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.