Bug 1421308 - [rbd-mirror] : image metadata is not synced to any secondary site(had multiple secondary site)
Summary: [rbd-mirror] : image metadata is not synced to any secondary site(had multipl...
Keywords:
Status: CLOSED DUPLICATE of bug 1344212
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2.2
Assignee: Jason Dillaman
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 23:58 UTC by Rachana Patel
Modified: 2017-07-30 15:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-11 01:04:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rachana Patel 2017-02-10 23:58:53 UTC
Description of problem:
========================
image is synced to secondary but image metadata is not synced to any of the secondary site


Version-Release number of selected component (if applicable):
==============================================================
10.2.5-13.el7cp.x86_64


How reproducible:
=================
always


Steps to Reproduce:
===================
1. had a ceph cluster where one site is primary for mirrorring and 2 sites are secondary.(each site have one MON, 3 OSD and 1rbd-mirror node)
2. Enabled pool level mirroring on pool data1
3. created few images in pool data1. all images were synced to both secondaries
4. set metadata for images on primary site

[root@magna043 ubuntu]# rbd image-meta list data1/dataset10new --cluster master
There are 2 metadatas on this image.
Key Value 
key1 value1 
key2 value2

5. verify metadata on secondary site

Actual results:
===============
no metadata is listed
[root@magna100 ubuntu]# rbd image-meta list i-mirror/dataset10new --cluster slave1
[root@magna100 ubuntu]# 

Expected results:
==================
metadata should be synced to secondary site


Additional info:

Comment 2 Jason Dillaman 2017-02-11 01:04:26 UTC

*** This bug has been marked as a duplicate of bug 1344212 ***


Note You need to log in before you can comment on or make changes to this bug.