Bug 1344262 - Disabling a feature from Master Node, is not getting reflected on Slave Node
Summary: Disabling a feature from Master Node, is not getting reflected on Slave Node
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: 3.0
Assignee: Jason Dillaman
QA Contact: Parikshith
Bara Ancincova
URL:
Whiteboard:
Keywords:
: 1446120 (view as bug list)
Depends On:
Blocks: 1322504 1383917 1412948 1494421
TreeView+ depends on / blocked
 
Reported: 2016-06-09 09:40 UTC by Tanay Ganguly
Modified: 2017-12-05 23:29 UTC (History)
6 users (show)

(edit)
.Dynamic feature updates are now replicated

When a feature was disabled or enabled on an already existing image and the image was mirrored to a peer cluster, the feature was not disabled or enabled on the replicated image. With this update, dynamic features updates are replicated as expected.
Clone Of:
(edit)
Last Closed: 2017-12-05 23:29:38 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC
Ceph Project Bug Tracker 16213 None None None 2016-06-09 12:22 UTC

Description Tanay Ganguly 2016-06-09 09:40:25 UTC
Description of problem:
Disabling a feature from Master Node, is not getting reflected on Slave Node even after resync completes.

Version-Release number of selected component (if applicable):
rbd-mirror-10.2.1-12.el7cp.x86_64

How reproducible:


Steps to Reproduce:
1. Create an Image without enabling Journal
2. Write some data onto it.
3. Enable Journal
rbd image 'tanay12':
        size 8191 MB in 2048 objects
        order 22 (4096 kB objects)
        block_name_prefix: rbd_data.136a2ae8944a
        format: 2
        features: layering, exclusive-lock, object-map, fast-diff, journaling
        flags: 
        journal: 136a2ae8944a
        mirroring state: enabled
        mirroring global id: b17134d1-087f-48c5-9af4-c52ff035f634
        mirroring primary: true
4. Again start IO on Master Node.
5. While IO is going ON, disable deep-flatten
rbd feature disable RBD/tanay12 deep-flatten --cluster master

Actual results:
On master Node deep-flatten got disabled, but on the Slave Node the image still have deep-flatten enabled.

Master:

rbd image 'tanay12':
        size 8191 MB in 2048 objects
        order 22 (4096 kB objects)
        block_name_prefix: rbd_data.136a2ae8944a
        format: 2
        features: layering, exclusive-lock, object-map, fast-diff, journaling
        flags: 
        journal: 136a2ae8944a
        mirroring state: enabled
        mirroring global id: b17134d1-087f-48c5-9af4-c52ff035f634
        mirroring primary: true

Slave:
rbd image 'tanay12':
        size 8191 MB in 2048 objects
        order 22 (4096 kB objects)
        block_name_prefix: rbd_data.394e12200854
        format: 2
        features: layering, exclusive-lock, object-map, fast-diff, deep-flatten, journaling
        flags: 
        journal: 394e12200854
        mirroring state: enabled
        mirroring global id: b17134d1-087f-48c5-9af4-c52ff035f634
        mirroring primary: false

Expected results:
The Feature should also get disabled in Slave Node.

Additional info:

Comment 2 Jason Dillaman 2016-06-09 11:59:22 UTC
Dynamic feature updates are not replicated and would be a large effort to implement.

Comment 8 Jason Dillaman 2016-09-26 16:28:55 UTC
Upstream, master branch PR: https://github.com/ceph/ceph/pull/10980

Comment 11 Jason Dillaman 2017-04-27 11:47:12 UTC
*** Bug 1446120 has been marked as a duplicate of this bug. ***

Comment 18 errata-xmlrpc 2017-12-05 23:29:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.