Bug 1446120 - [RBD-mirror] - Disabling image feature in primary cluster is not getting reflected in secondary cluster
Summary: [RBD-mirror] - Disabling image feature in primary cluster is not getting refl...
Keywords:
Status: CLOSED DUPLICATE of bug 1344262
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.4
Assignee: Jason Dillaman
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-27 09:54 UTC by Vasishta
Modified: 2017-07-30 15:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-27 11:47:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
A sample doc of terminal log having information on steps I followed and corresponding terminal output (4.80 KB, text/plain)
2017-04-27 09:56 UTC, Vasishta
no flags Details

Description Vasishta 2017-04-27 09:54:08 UTC
Description of problem:
Disabling some image features of an image in 'pool mirroring' enabled pool in primary cluster is not getting reflected in corresponding image of corresponding pool in secondary cluster.

Version-Release number of selected component (if applicable):
ceph version 10.2.7-13.el7cp 

How reproducible:
Always

Steps to Reproduce:
1. Follow section 4.5 in Block Device guide to Configure pool mirroring.
2. Create a image and enable journaling feature and make sure that it has got mirrored to secondary cluster.
3. For above image in primary cluster disable image features like fast-diff, object-map and deep-flatten 

Actual results:
Image in secondary doesn't reflect corresponding image in primary cluster properly

Expected results:
Image in secondary must reflect corresponding image in primary cluster properly

Additional info:
Couldn't observe any issue with data synchronization.

Comment 2 Vasishta 2017-04-27 09:56:39 UTC
Created attachment 1274555 [details]
A sample doc of terminal log having information on steps I followed and corresponding terminal output

Comment 3 Jason Dillaman 2017-04-27 11:47:12 UTC

*** This bug has been marked as a duplicate of bug 1344262 ***


Note You need to log in before you can comment on or make changes to this bug.