Bug 1344290 - Calamari api /api/v2/cluster/<fsid>/server returns OSD server names with crush bucket names appended
Summary: Calamari api /api/v2/cluster/<fsid>/server returns OSD server names with crus...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Christina Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-06-09 10:52 UTC by Shubhendu Tripathi
Modified: 2016-08-23 19:41 UTC (History)
7 users (show)

Fixed In Version: calamari-server-1.4.1-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:41:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
fqdn showing shortname (7.51 KB, text/plain)
2016-06-15 10:37 UTC, Harish NV Rao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Shubhendu Tripathi 2016-06-09 10:52:42 UTC
Description of problem:
The calamari api /api/v2/cluster/<fsid>/server returns OSD server names with crush bucket names appended.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a cluster with say 1 mon and 1 osd node
2. Check the calamari api mentioned above (/api/v2/cluster/<fsid>/server)
3.

Actual results:
The output looks like below 

-----------------------------
[
    {
        "fqdn": "dhcp46-150.lab.eng.blr.redhat.com-general", 
        "hostname": "dhcp46-150.lab.eng.blr.redhat.com-general", 
        "services": [
            {
                "fsid": "f32fc340-779c-4233-bec3-d3a3ba354864", 
                "type": "osd", 
                "id": "0", 
                "running": true
            }
        ], 
        "frontend_addr": "10.70.46.150", 
        "backend_addr": "10.70.46.150", 
        "frontend_iface": null, 
        "backend_iface": null, 
        "managed": false, 
        "last_contact": null, 
        "boot_time": null, 
        "ceph_version": null
    }, 
    {
        "fqdn": "dhcp46-181.lab.eng.blr.redhat.com", 
        "hostname": "dhcp46-181.lab.eng.blr.redhat.com", 
        "services": [
            {
                "fsid": "f32fc340-779c-4233-bec3-d3a3ba354864", 
                "type": "mon", 
                "id": "dhcp46-181", 
                "running": true
            }, 
            {

Expected results:
The hostname and fqdn for the OSD nodes should not have appended "-general"


Additional info:
The snippet from de-compiled crushmap is as below 

-------------------------------------------------
# buckets
host dhcp46-150 {
        id -2           # do not change unnecessarily
        # weight 0.000
        alg straw
        hash 0  # rjenkins1
}
root default {
        id -1           # do not change unnecessarily
        # weight 0.000
        alg straw
        hash 0  # rjenkins1
        item dhcp46-150 weight 0.000
}
host dhcp46-150.lab.eng.blr.redhat.com-general {
        id -3           # do not change unnecessarily
        # weight 0.000
        alg straw
        hash 0  # rjenkins1
        item osd.0 weight 0.000
}
root general {
        id -4           # do not change unnecessarily
        # weight 0.000
        alg straw
        hash 0  # rjenkins1
        item dhcp46-150.lab.eng.blr.redhat.com-general weight 0.000
}
---------------------------

Comment 2 Shubhendu Tripathi 2016-06-09 10:54:11 UTC
This causes import cluster flow broken in USM...

Comment 3 Christina Meno 2016-06-10 04:32:53 UTC
I can fix this. It's not going to be easy. I'll try to have it in by the 6.13 build

Comment 5 Nishanth Thomas 2016-06-13 16:31:01 UTC
Hope this change returns proper fqdn. The same applicable for /api/v2/cluster/<fsid>/osd api as well

Comment 6 Shubhendu Tripathi 2016-06-14 05:51:31 UTC
Gregory all the FQDN names should have domain names properly populated and not like dhcp46-239. Rather it should be shown as say "dhcp46-239.lab.eng.blt.redhat.com" ..

Comment 8 Christina Meno 2016-06-14 19:23:26 UTC
Yes this will provide a proper FQDN for /server and /osd

Comment 10 Harish NV Rao 2016-06-15 10:36:05 UTC
fqdn is displayed properly for the mon where calamari-lite is running. For rest of the nodes, it displays only host shortname. 

output of  /api/v2/cluster/<fsid>/server will be attached.

Tested on:
calamari-server-1.4.1-1.el7cp.x86_64
ceph version 10.2.2-1.el7cp

Comment 11 Harish NV Rao 2016-06-15 10:37:01 UTC
Created attachment 1168309 [details]
fqdn showing shortname

Comment 12 Christina Meno 2016-06-15 20:46:28 UTC
Harish the original issue in this BZ was fixed. We've got a new issue that captures what you observed: https://bugzilla.redhat.com/show_bug.cgi?id=1346207

Would you please file new BZs where there are issues that are identified around the initial issue?

Comment 13 Shubhendu Tripathi 2016-06-17 12:12:10 UTC
Find this working with build calamari-server-1.4.2-1.el7cp.x86_64

Comment 14 Harish NV Rao 2016-06-20 10:23:31 UTC
I will be creating a separate defect for the issue found in comment 10
For now, based on comment 13, moving this defect to verified state.

Comment 16 errata-xmlrpc 2016-08-23 19:41:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.