Bug 134442 - grub doesn't scroll properly in gnome-terminal
grub doesn't scroll properly in gnome-terminal
Status: CLOSED DUPLICATE of bug 128375
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-02 15:41 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-10-02 15:41:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
If a grub session started within a gnome-terminal is long enough to
require scrolling, the screen becomes garbled since not all of the
terminal scrolls, and new output is often lost.  The problem does not
occur in the console (VT1), nor does it occur in xterms.  I haven't
tried konsole or other terminal emulation programs.

Version-Release number of selected component (if applicable):
grub-0.95-2
gnome-terminal-2.7.3-1
vte-0.11.11-5

How reproducible:
Always

Steps to Reproduce:
1.Start gnome-terminal.  Resize to, say, 80x25.
2.start grub (don't bother to become root; better not, to avoid mistakes)
3.Issue commands such as `root (hd0,0)' repeatedly.  It doesn't matter
if it makes sense, just get it to keep generating output until you'd
expect it to start scrolling.  Just pressing ENTER might be good
enough to observe the problem, but having some error messages along
the way helps figure out what happens (or fails to :-)

Actual Results:  When it should begin scrolling, it begins garbling
the screen

Expected Results:  Regular scrolling, just like in text consoles and xterm

Additional info:

If you happen to run 2 or 3 setup commands in a single session, you
won't be able to tell whether the last ones completed successfully. 
This is bad. 

If you resize gnome-terminal to say 79x25, it's even worse: the
initial cursor will be one line below the initial prompt.
Comment 1 Jeremy Katz 2004-10-03 11:32:34 EDT
Is it any better if you set TERM to xterm before running grub?
Comment 2 Alexandre Oliva 2004-10-04 12:23:28 EDT
It was already xterm (but why? does gnome-terminal actually implement
an xterm terminal?).  FWIW, setting it to vt100 appears to work around
the problem.
Comment 3 Bill Nottingham 2004-10-04 12:54:16 EDT
Does it work better with TERM=gnome?
Comment 4 Alexandre Oliva 2004-10-04 14:13:54 EDT
Yup, TERM=gnome fixes it.
Comment 5 Eido Inoue 2004-10-04 14:45:42 EDT
if setting TERM to gnome fixes it, the problem isn't ncurses-- it's
gnome-terminal-- gnome-terminal is not 100% compatible with xterm, but
we leave TERM set to stock xterm (our xterm definition is
unpatched/unmodified for this reason and will stay that way) for
compatiblity with many different terminals.
Comment 6 Ray Strode [halfline] 2004-11-04 01:12:31 EST

*** This bug has been marked as a duplicate of 128375 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:06:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.