Bug 128375 - gnome-terminal corruption
gnome-terminal corruption
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ncurses (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
: 134442 138548 141180 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-22 07:05 EDT by Jay Turner
Modified: 2015-01-07 19:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 16:37:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen corruption (117.16 KB, image/png)
2004-07-22 07:06 EDT, Jay Turner
no flags Details
More corruption (101.32 KB, image/png)
2004-07-22 07:06 EDT, Jay Turner
no flags Details
Screen after <ctrl>-L to refresh (102.65 KB, image/png)
2004-07-22 07:07 EDT, Jay Turner
no flags Details
screen corruption (117.16 KB, image/png)
2004-07-22 07:08 EDT, Jay Turner
no flags Details

  None (edit)
Description Jay Turner 2004-07-22 07:05:02 EDT
Description of problem:
Details are sketchy, and not even really sure that vte is at fault,
but with vte-0.11.10-5.1 and gnome-terminal-2.6.0-4, I'm seeing
corruption in a gnome-terminal when running mutt.  I've not seen the
corruption outside of mutt, so mutt might be at fault.  Normally
everything is alright, but from time to time, it appears that a
portion of the screen won't update, leaving dangling text.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Turner 2004-07-22 07:06:02 EDT
Created attachment 102135 [details]
screen corruption
Comment 2 Jay Turner 2004-07-22 07:06:41 EDT
Created attachment 102136 [details]
More corruption
Comment 3 Jay Turner 2004-07-22 07:07:30 EDT
Created attachment 102137 [details]
Screen after <ctrl>-L to refresh
Comment 4 Jay Turner 2004-07-22 07:08:24 EDT
Created attachment 102138 [details]
screen corruption
Comment 5 Eido Inoue 2004-10-08 12:05:24 EDT
either TERM needs to be set to "gnome" or gnome-terminal needs to fix
its xterm emulation.
Comment 6 Ray Strode [halfline] 2004-11-04 01:12:39 EST
*** Bug 134442 has been marked as a duplicate of this bug. ***
Comment 7 Jay Turner 2004-11-04 07:36:04 EST
Indeed setting TERM=gnome does resolve the problem.  Would be really,
really nice if this were a commandline option (hint, hint).  Leaving
the bug open, as the xterm emulation doesn't has some warts.
Comment 8 Ray Strode [halfline] 2004-11-04 19:49:04 EST
Hi Jay,

If you use a version of vte >= 0.11.11-7 (from rawhide) does it fix
your problem?
Comment 9 Jay Turner 2004-11-05 04:54:05 EST
Nope, updating to 0.11.11-10 with both gnome-terminal-2.7.3-1 and
gnome-terminal-2.8.0-2 still gives me the same behavior.
Comment 10 Ray Strode [halfline] 2004-11-09 16:19:17 EST
*** Bug 138548 has been marked as a duplicate of this bug. ***
Comment 11 Richard Henderson 2004-11-09 16:33:25 EST
For the record, I don't believe having a separate TERM=gnome setting
is the best alternative.  TERM=xterm is well supported on many legacy
systems that one may still need to work with, whereas these systems
won't know anything about terminal type gnome.

I can't see this as anything but bugs in gnome-terminal that really
ought to be fixed.
Comment 12 Ray Strode [halfline] 2004-11-09 16:36:01 EST
Hi Richard,

We all agree with you.  It just hasn't happened yet.  Bill was giving
you a workaround in the interim.
Comment 13 Eido Inoue 2004-11-29 16:47:50 EST
*** Bug 141180 has been marked as a duplicate of this bug. ***
Comment 14 H.J. Lu 2004-11-29 20:29:24 EST
FWIW, I reverted to ncurses-5.4-5, which fixed the problem for me.
Comment 15 Warren Togami 2005-05-12 17:04:16 EDT
Is this still an issue in RHEL4?
Comment 16 H.J. Lu 2005-05-12 17:06:59 EDT
I saw it in FC-3 with all the updates.
Comment 17 Warren Togami 2005-05-12 17:10:40 EDT
Even the vte-0.11.12 update?
Comment 19 Anthony J. Ciani 2005-08-29 15:24:06 EDT
Downgrading ncurses to 5.4-5 (from ncurses 5.4-13 / FC3) fixed the problem for
me as well.  Nothing I did with vte worked.  This is probably not a vte problem.
Comment 20 Warren Togami 2005-12-13 16:37:18 EST
With no definite details, there is probably nothing we can do here.  Please open
specific issues that you are able to reproduce at the upstream GNOME Bugzilla.
Comment 21 Michal Jaegermann 2006-03-06 16:35:38 EST
I hit the same problem and spent some too much time trying to find out
what gnome-terminal can be doing for me.  Eventually it downed on me that
a terminfo entry may be responsible for that mess (unless the problem really
is that gnome-terminal is not doing correctly xterm stuff as doing the same
in xterm window does not have issues).

It is not necessary to drop the whole ncurses package to 5.4-5 level.
It is enough just to replace /usr/share/terminfo/x/xterm with the old one
and the problem disappears. 'infocmp' shows a long list of differences between
these two descriptions.  Function key assignments are not likely the issue
here but even without those there is still enough left.

BTW - using here an xterm description from ncurses-5.4-17 (FC4) gives the
same troubles.  That is not surprising as infocmp for those two shows only
this (names are my own so I can identify files):

comparing xterm-5.4-13 to xterm-5.4-17.
    comparing booleans.
    comparing numbers.
    comparing strings.
        kbs: '^H', '\177'.
Comment 22 Michal Jaegermann 2006-03-06 17:00:41 EST
I should add that replacing /usr/share/terminfo/x/xterm provides a bit
of a relief but it is not a solution.  After logging on a remove machine
/usr/share/terminfo/x/xterm from there seems to be used and not a local one.
Comment 23 Michal Jaegermann 2006-03-06 17:27:00 EST
I am afraid that leaving that CLOSED UPSTREAM is not of much help.
"Upstream" will tell you "just use a newer version" and I just checked
that at least gnome-terminal-2.13.93-1 from the current "rawhide" does
not have that problem.  OTOH systems using gnome-terminal-2.7.3 will
be around for quite a while and just recompiling something newer is not
a realistic option. Even gnome-terminal-2.10.x needs various updated
libraries or it will not link.

BTW - my suspicions would be first on 'setf' and 'setb' string handling.
Both 'gnome' and an old 'xterm' have these set to NULL.
Comment 24 keithu@parl.clemson.edu 2006-04-12 03:01:40 EDT
I have to agree with Michal.  I expect a major bug (my manifestation is screen
corruption using ispell) in a critical component (the default terminal) of a
supposedly supported platform to either have an open bug against it or have a
workable solution.  

Since the bug is closed, what is the workable solution?

Note You need to log in before you can comment on or make changes to this bug.