Bug 134508 - Cannot download DVD image: file is > 2 Gbytes
Cannot download DVD image: file is > 2 Gbytes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-release (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
Bill Nottingham
ftp://mirror.cpsc.ucalgary.ca/mirror/...
:
: 135652 (view as bug list)
Depends On:
Blocks: fc-relnotes-blocker
  Show dependency treegraph
 
Reported: 2004-10-04 02:07 EDT by Konstantin Olchanski
Modified: 2014-03-16 22:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 13:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Olchanski 2004-10-04 02:07:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040806

Description of problem:
My favourite file downloading tools cannot download the x86_64
Fedora-2 DVD image because it is bigger than 2 Gbytes. I am using wget
and ftpcopy from i386 Fedora-2, and both fail with the familiar "file
size limit exceeded" error.

But this is not the subject of this bug: I am sure this little defect
in both wget and ftpcopy will be fixed, eventually.

I am writing this to suggest that this little gotcha should be
documented in the Fedora release notes (I just checked FC3+ release
notes- they say naught about file size problems with downloading DVD
images).

Perhaps the release notes should also suggest a file downloading
program known to support large files.

K.O.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. wget -c
ftp://mirror.cpsc.ucalgary.ca/mirror/fedora/linux/core/2/x86_64/dvd-iso/FC2-x86_64-DVD.iso
2.
3.
    

Actual Results:  Core dump, output file is truncated at 2 Gbytes:
[olchansk@send x86_64]$ wget -c
ftp://mirror.cpsc.ucalgary.ca/mirror/fedora/linux/core/2/x86_64/dvd-iso/FC2-x86_64-DVD.iso
--23:05:32-- 
ftp://mirror.cpsc.ucalgary.ca/mirror/fedora/linux/core/2/x86_64/dvd-iso/FC2-x86_64-DVD.iso
           => `FC2-x86_64-DVD.iso'
Resolving mirror.cpsc.ucalgary.ca... done.
Connecting to mirror.cpsc.ucalgary.ca[136.159.12.11]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD
/mirror/fedora/linux/core/2/x86_64/dvd-iso ... done.
==> SIZE FC2-x86_64-DVD.iso ... done.
==> PORT ... done.    ==> REST 2147483647 ... done.    
==> RETR FC2-x86_64-DVD.iso ... done.
Length: -21,870,592 [2,125,613,057 to go] (unauthoritative)

100%[===============================================================================>]
2,147,483,647   --.--K/s    ETA --:--File size limit exceeded


Expected Results:  The Fedora README file should suggest a
known-to-work way to download DVD images (I am sure one exists).


Additional info:

This is NOT about bugs in wget and ftpcopy.

This is about adding "DVD download instructions" to the Fedora
distribution README files.
Comment 1 Bill Nottingham 2004-10-04 11:23:18 EDT
Assigning to the relnotes person.
Comment 2 Ed Bailey 2004-10-12 12:10:38 EDT
After doing some testing, it looks like ncftpget and curl work
properly with large files.  I'll get this added to the docs...
Comment 3 Ed Bailey 2004-10-15 16:54:08 EDT
*** Bug 135652 has been marked as a duplicate of this bug. ***
Comment 4 Ed Bailey 2004-10-18 13:56:11 EDT
This text is not part of the release notes (at the top of the
"installation-related notes" section):

Note

If you intend to download the Fedora Core 2.92 Test 3 DVD ISO image,
keep in mind that not all file downloading tools can accommodate files
larger than 2GB in size. For example, wget will exit with a File size
limit exceeded error.

The curl and ncftpget file downloading tools do not have this
limitation, and can successfully download files larger than 2GB.

(Note that the version will change as appropriate when the time
comes... :-)

Note You need to log in before you can comment on or make changes to this bug.