Bug 134510 - firstboot starting in runlevel 3
Summary: firstboot starting in runlevel 3
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: firstboot   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
: 134332 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-04 06:43 UTC by Berthold Cogel
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 21:46:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Berthold Cogel 2004-10-04 06:43:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.2)
Gecko/20040806

Description of problem:
firstboot is started in runlevel 3.
According to firstboot itself it should only be started in runlevel 5.
  We are booting with serial console which makes running firstboot
even more useless.

 

Version-Release number of selected component (if applicable):
firstboot-1.1.19-2

How reproducible:
Didn't try

Steps to Reproduce:
1.Install System with kickstart
2.Boot with serial console
3.Watch the fun
    

Actual Results:  First boot is started

Additional info:

I'm trying to reproduce it with the next installation.

Comment 1 Adrian Likins 2004-10-04 21:40:21 UTC
odd. 1.1.19 has code to explicitly detect
if its in runlevel 3.

whats the output of `/sbin/runlevel` say on
that box?

Comment 2 Adrian Likins 2004-10-04 21:42:10 UTC
*** Bug 134332 has been marked as a duplicate of this bug. ***

Comment 3 Berthold Cogel 2004-10-07 13:01:37 UTC
It happened again yesterday on another machine during a fresh install.
I got a 'firstboot [OK]' during the first boot after the installation.
This time on the local console.
And /sbin/runlevel gives 'N 3'.





Comment 4 Jeremy Katz 2005-07-06 21:46:28 UTC
firstboot has a text mode now and is intended to start in all default runlevels.


Note You need to log in before you can comment on or make changes to this bug.