Bug 134511 - Edit Preferences crashes Sound-Juicer
Edit Preferences crashes Sound-Juicer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 134628 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-10-04 03:37 EDT by Dee-Ann LeBlanc
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.13-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 18:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dee-Ann LeBlanc 2004-10-04 03:37:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
I place the Tea Party album Alhambra in the CD drive, open
sound-juicer, click Edit -> Preferences, and sound-juicer crashes.

Version-Release number of selected component (if applicable):
sound-juicer-0.5.13-1

How reproducible:
Always

Steps to Reproduce:
1. As above
2.
3.
    

Actual Results:  Crash bang boom.

Expected Results:  I should get the Preferences menu.

Additional info:
Comment 1 Bryan W Clark 2004-10-04 14:29:02 EDT
Easy backtrace to get:

(gdb) run
Starting program: /usr/bin/sound-juicer
[Thread debugging using libthread_db enabled]
[New Thread -1208077280 (LWP 13727)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208077280 (LWP 13727)]
0x08051e4e in file_pattern_changed_cb (client=0x87d1c60,
cnxn_id=4294967295,
    entry=0x8918f50, user_data=0x0) at sj-prefs.c:392
392       g_return_if_fail (entry->value->type == GCONF_VALUE_STRING);
(gdb) bt
#0  0x08051e4e in file_pattern_changed_cb (client=0x87d1c60,
    cnxn_id=4294967295, entry=0x8918f50, user_data=0x0) at sj-prefs.c:392
#1  0x080521dc in on_edit_preferences_cb (item=0x8811d30, user_data=0x0)
    at sj-prefs.c:468
#2  0x004780ae in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#3  0x00460347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4  0x0047594e in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#5  0x004779bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#6  0x00477c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7  0x008826f9 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x0079e300 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#9  0x0079e60a in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0x00794d1d in gtk_menu_reorder_child () from
/usr/lib/libgtk-x11-2.0.so.0
#11 0x0078eda7 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x004606b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#13 0x00460347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0x00476576 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#15 0x00477613 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#16 0x00477c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0x00882885 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x0078d06b in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x0078d370 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x00644092 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#21 0x003c54fb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#22 0x003c6f82 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#23 0x003c722f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#24 0x0078c6ce in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x08051176 in main (argc=143757136, argv=0x8918f50) at sj-main.c:1056

------------------------------

Found the problem to be a missing defaults directory:
/etc/gconf/gconf.xml.defaults/apps/sound-juicer/
                                    ^^ doesn't exist

Gconf values aren't being initialized, which is causing the crash.
Comment 2 Colin Walters 2004-10-05 10:16:37 EDT
*** Bug 134628 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.