Bug 134628 - Sound-jucier crashes when opening preferences menu
Sound-jucier crashes when opening preferences menu
Status: CLOSED DUPLICATE of bug 134511
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 03:56 EDT by Håvard Wigtil
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Håvard Wigtil 2004-10-05 03:56:21 EDT
Version-Release number of selected component (if applicable):
sound-juicer-0.5.13-1

How reproducible:
Always

Steps to Reproduce:
1. Start sound-juicer
2. Open Edit -> Preferences
  
Actual results:
Instant crash

Expected results:
Edit preferences

Backtrace from gdb:
(gdb) thread apply all bt

Thread 1 (Thread -152320992 (LWP 3966)):
#0  0x08051d42 in path_pattern_changed_cb (client=0x9a15c28,
cnxn_id=4294967295, entry=0x9c03f08, user_data=0x0)
    at sj-prefs.c:371
#1  0x0805222a in on_edit_preferences_cb (item=0x9a58c50,
user_data=0x0) at sj-prefs.c:469
#2  0x001220ae in g_cclosure_marshal_VOID__VOID (closure=0x9a89f00,
return_value=0x0, n_param_values=1, param_values=0x0,
    invocation_hint=0xfee32608, marshal_data=0x0) at gmarshal.c:77
#3  0x0010a347 in g_closure_invoke (closure=0x9a89f00,
return_value=0x0, n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#4  0x0011f94e in signal_emit_unlocked_R (node=0x9a4c2d0, detail=0,
instance=0x9a58c50, emission_return=0x0,
    instance_and_params=0xfee32730) at gsignal.c:2435
#5  0x001219bc in g_signal_emit_valist (instance=0x9a58c50,
signal_id=1, detail=0,
    var_args=0xfee328bc "\230\213�\t\b)���\226�") at gsignal.c:2194
#6  0x00121c5a in g_signal_emit (instance=0x0, signal_id=0, detail=0)
at gsignal.c:2238
#7  0x005346f9 in gtk_widget_activate (widget=0x9a58c50) at
gtkwidget.c:3594
#8  0x00450300 in gtk_menu_shell_activate_item (menu_shell=0x9a571f8,
menu_item=0x9a58c50, force_deactivate=1)
    at gtkmenushell.c:892
#9  0x0045060a in gtk_menu_shell_button_release (widget=0x9a571f8,
event=0x9bcd4c8) at gtkmenushell.c:511
#10 0x00446d1d in gtk_menu_button_release (widget=0x9a571f8,
event=0x0) at gtkmenu.c:2494
#11 0x00440da7 in _gtk_marshal_BOOLEAN__BOXED (closure=0x9a25f90,
return_value=0xfee32ba0, n_param_values=2,
    param_values=0xfee32cf0, invocation_hint=0xfee32bc8,
marshal_data=0x446cc4) at gtkmarshalers.c:82
#12 0x0010a6b2 in g_type_class_meta_marshal (closure=0x9a25f90,
return_value=0x0, n_param_values=0, param_values=0xfee32cf0,
    invocation_hint=0x0, marshal_data=0x0) at gclosure.c:514
#13 0x0010a347 in g_closure_invoke (closure=0x9a25f90,
return_value=0x0, n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#14 0x00120576 in signal_emit_unlocked_R (node=0x9a25fe8, detail=0,
instance=0x9a571f8, emission_return=0xfee32c90,
    instance_and_params=0xfee32cf0) at gsignal.c:2473
#15 0x00121613 in g_signal_emit_valist (instance=0x9a571f8,
signal_id=0, detail=0, var_args=0xfee32e80 "\210.���q�\t")
    at gsignal.c:2204
#16 0x00121c5a in g_signal_emit (instance=0x0, signal_id=0, detail=0)
at gsignal.c:2238
#17 0x00534885 in gtk_widget_event_internal (widget=0x9a571f8,
event=0x9bcd4c8) at gtkwidget.c:3563
#18 0x0043f06b in gtk_propagate_event (widget=0x9a571f8,
event=0x9bcd4c8) at gtkmain.c:2345
#19 0x0043f370 in gtk_main_do_event (event=0x9bcd4c8) at gtkmain.c:1583
#20 0x002f6092 in gdk_event_dispatch (source=0x0, callback=0,
user_data=0x0) at gdkevents-x11.c:2184
#21 0x00d6b4fb in g_main_context_dispatch (context=0x9a0b0b0) at
gmain.c:1942
#22 0x00d6cf82 in g_main_context_iterate (context=0x9a0b0b0, block=1,
dispatch=1, self=0x9977360) at gmain.c:2573
#23 0x00d6d22f in g_main_loop_run (loop=0x9bd9068) at gmain.c:2777
#24 0x0043e6ce in gtk_main () at gtkmain.c:1173
#25 0x08051176 in main (argc=163593992, argv=0x9c03f08) at sj-main.c:1056
Comment 1 Håvard Wigtil 2004-10-05 04:01:32 EDT
When I use gconf-editor to edit s-j preferences, I get a warning that
no schema is installed ("This key has no schema") for any of the three
keys I have available.

The schema file is installed as /etc/gconf/schemas/sound-juicer.schemas
Comment 2 Colin Walters 2004-10-05 10:16:36 EDT

*** This bug has been marked as a duplicate of 134511 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.