This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 134521 - FC2 Update from RH8- Unhandled Exception
FC2 Update from RH8- Unhandled Exception
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
: 150851 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2004-10-04 08:12 EDT by Colin Ager
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 17:39:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anacom Dump (68.00 KB, text/plain)
2004-10-04 11:43 EDT, Colin Ager
no flags Details
hda6 /etc/fstab (1.14 KB, text/plain)
2005-05-10 04:10 EDT, Colin Ager
no flags Details

  None (edit)
Description Colin Ager 2004-10-04 08:12:43 EDT
Update from DVD fails after screen at which old system identified


Version-Release number - Not Known- Magazine Disk


How reproducible: Every Time


Steps to Reproduce:
1.Boot from DVD follow screen prompts
2.Click on Next at screen which identifies old system
3.
  
Actual results: Error message -Unhandled Exception Error- Suggest
probably bug- file bug report on anaconda- Dump log to floppy- 


Expected results:Continuation of Update process.


Additional info:Trying FC1 DVD contiues past this point without
trouble but I have not committed at the final point on this upgrade.

Machine is an Asus P3-800 with four SCSI peripherals Prior to the
abort point message seen saying "could not align partitions-non fatal"
Comment 1 Jeremy Katz 2004-10-04 08:46:21 EDT
Can you provide the traceback you received?
Comment 2 Colin Ager 2004-10-04 11:43:22 EDT
Created attachment 104722 [details]
Anacom Dump
Comment 3 Jeremy Katz 2004-10-04 12:02:01 EDT
Should be fixed in newer code.
Comment 5 Chris Lumens 2005-03-11 11:34:16 EST
*** Bug 150851 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2005-04-19 10:47:54 EDT
What are you upgrading from, and what sort of partition layout are you starting
out with?  I'd be interested to see if this is still happening with fc4test2.
Comment 7 Colin Ager 2005-04-22 14:12:38 EDT
At the time I originally reported the bug I was using a dual boot system with
RH8 booted from a floppy boot disk. The partition arrangement was as follows

Disk0 sda1 was Win98  "C" fat16
      sda2 was    win "E" fat16
      sda3 was    win "F" fat16

Disk1 hda1 was    win "D" fat32
      hda2 was    win "G" fat32
      hda3 was    win "H" fat32
      hda4 was    win "I" fat32
      hda5 was    win "J" fat32
      hda6 was RH8        ext3
      hda7 was linux      swap

As I could not get either the FC2 or FC3 magazine disks to upgrade my RH8
installation I have now fitted a third hard drive which alowed me to install as
follows:
      hdb1     WinXP      ntfs  
      hdb2     FC3        ext3 Clean Install
      hdb3     /home      ext3
      hdb4/5   linux      swap
I boot this lot from a GRUB boot floppy.
I havn't been able to download FC4-test as my broadband link is via a radio and
satellite link and usually drops out before I get to the end! I will wait till
FC4 apopears on a magazine disk before trying it as I don't want to fry my RH8 OS.

Colin
   
Comment 8 Chris Lumens 2005-05-05 15:10:52 EDT
Can you post your hda6's /etc/fstab?
Comment 9 Chris Lumens 2005-05-05 15:17:01 EDT
For what it's worth, I don't believe you will get this exception anymore on FC4
because it looks like we're handling the case where root is None.  That doesn't
mean this will work - you'll just get an error dialog explaining the situation
instead of an exception.  It's a friendlier error, but still an error.
Comment 10 Colin Ager 2005-05-10 04:10:42 EDT
Created attachment 114193 [details]
hda6 /etc/fstab

As requested

Note You need to log in before you can comment on or make changes to this bug.