Bug 134548 - Too limited control over boot params
Too limited control over boot params
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-boot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature, Patch
: 145136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 11:34 EDT by Mikael Carneholm
Modified: 2014-05-08 12:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: mailman-2.1.9-5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 12:42:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add fallback setting (2.70 KB, patch)
2008-04-11 19:59 EDT, ray hammond
no flags Details | Diff

  None (edit)
Description Mikael Carneholm 2004-10-04 11:34:31 EDT
Description of problem:
s-c-b currently only allows you to choose which boot post that should
be default, and timeout delay. This is much too limited! For a
successful OS, TUSNHTRTAT(TM) (The User Should Never Have To Resort To
A Terminal)

You should at least be able to control:
// stored in grub.conf
- rhgb (on/off)
- vga mode
- kernel verboseness (quiet/silent/..)
// stored in inittab
- initial runlevel

Version-Release number of selected component (if applicable):
0.2.7-1
Comment 1 Mikael Carneholm 2004-10-04 11:39:00 EDT
TUSNHTRTAT(TM) is also known as TSBAGFE(TM) (There Should Be A GUI For
Everything)
Comment 2 Harald Hoyer 2004-10-04 12:21:20 EDT
WAP(TM) AKA We accept patches!
Comment 3 Rahul Sundaram 2005-08-13 16:47:25 EDT
*** Bug 145136 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2007-01-29 09:28:10 EST
oops, wrong bug :)
Comment 5 ray hammond 2008-04-11 18:50:15 EDT
grub.conf also permits the usage of the failback option: unfortunately, the
option is not available through the systen-config-boot utility. I guess there
should be a check box to permit the failover feature to be toggled.
Comment 6 ray hammond 2008-04-11 19:58:49 EDT
I got the terminology wrong It the fallback option no failback.  

Also I have added the fallback option to the source extracted from the SRC RPM
on rawhide; however, I have never created a patch.  I read a few documents on
the Internet but I am getting confused, I've submitted what I think is a patch.
 Apologies if this is wrong: this is the first patch I've submitted.
Comment 7 ray hammond 2008-04-11 19:59:50 EDT
Created attachment 302181 [details]
Patch to add fallback setting
Comment 8 John Poelstra 2008-07-04 00:23:40 EDT
triaged

Note You need to log in before you can comment on or make changes to this bug.