Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1346147 - Inside a gnome-wayland session, gnome-tweak-tool still offers "Icons on desktop: on/off"
Summary: Inside a gnome-wayland session, gnome-tweak-tool still offers "Icons on deskt...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1399364 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-14 06:28 UTC by Joachim Backes
Modified: 2016-12-08 16:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-08 16:31:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Backes 2016-06-14 06:28:00 UTC
Description of problem:

if running gnome-tweak-tool inside a gnome-on-wayland session, then it 
still offers the option: Icons on desktop on/off. But if choosing the on 
option, nothing happens, and still no desktop icons appear. This 
confuses the user.
Version-Release number of selected component (if applicable):

gnome-tweak-tool-3.20.1-1.fc24.noarch
How reproducible:

always
Steps to Reproduce:
1.Login to a gnome-on-wayland session
2.Start gnome-tweak-tool
3.

Actual results:
See description

Expected results:
Gnome-tweak-tool should not offer the this option (inside a gnome-wayland session), or the desktop icons should appear.

Additional info:

Comment 1 Joachim Backes 2016-06-14 08:11:35 UTC
If logging in into a gnome-wayland-session, then several variables are set which let you decide wether running wayland or not:

DESKTOP_SESSION=gnome-wayland
GDMSESSION=gnome-wayland
WAYLAND_DISPLAY=wayland-0
XDG_SESSION_DESKTOP=gnome-wayland
XDG_SESSION_TYPE=wayland

So it should be simple to decide whether wayland is running or not, and gnome-tweak-tool can decide to present the   "desktop icons button" or not.

Comment 2 Richard Fearn 2016-11-27 19:35:46 UTC
See also bug 1397624

Comment 3 giaborc 2016-11-30 13:26:16 UTC
*** Bug 1399364 has been marked as a duplicate of this bug. ***

Comment 4 Felix Schwarz 2016-12-08 16:31:05 UTC
As mentioned in bug 1397624 the GNOME developers enabled desktop icons on Wayland and this change will appear in the next minor release of 3.22 (and of course all future major releases).

F24 (which was mentioned in this bug report) still uses Gnome 3.20 which did not get the commit. As the fix is almost trivial (see https://bugzilla.gnome.org/show_bug.cgi?id=748347 for more details) a determined user should be able to test the change on 3.20 and convince the GNOME developers to add the commit also for the 3.20 branch.

However given the lack of feedback in this bug report I assume no one really cares enough for F24 to make that happen so I'm closing this as CLOSED/UPSTREAM (in the end this is not a fedora-specific bug but really just a missing feature).

(Sorry if I stepped on anyone's toes by closing this, feel free to reopen.)


Note You need to log in before you can comment on or make changes to this bug.