This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 134623 - (radeon 7000 dualhead) X locks
(radeon 7000 dualhead) X locks
Status: CLOSED DUPLICATE of bug 134766
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-05 01:04 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (52.03 KB, text/plain)
2004-10-05 01:05 EDT, Warren Togami
no flags Details
lspci -v (5.03 KB, text/plain)
2004-10-05 06:02 EDT, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2004-10-05 01:04:27 EDT
Description of problem:
A rawhide upgrade in the last few days caused X to lockup after a few
seconds of use when dual head is enabled on a Radeon 7000.  It was
working well only a few days ago.  When X locks up, all key and mouse
input fails at the local console, but ssh allows logins.  This error
repeats in Xorg.0.log many times:

(EE) RADEON(0): Idle timed out, resetting engine...

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100
QY [Radeon 7000/VE] (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc: Unknown device 1b8a
	Flags: stepping, 66Mhz, medium devsel, IRQ 11
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at ec00 [size=256]
	Memory at ff9f0000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at 80000000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

Attaching complete Xorg.0.log and lspci -v will be attached.

NOTE: Disabling dual head makes X stable again.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-4
Comment 1 Warren Togami 2004-10-05 01:05:12 EDT
Created attachment 104769 [details]
Xorg.0.log
Comment 2 Warren Togami 2004-10-05 06:02:44 EDT
Created attachment 104773 [details]
lspci -v
Comment 3 Warren Togami 2004-10-05 06:44:50 EDT
Elayne, please downgrade to the xorg-x11 from FC3test2 to confirm that
it works with that slightly older version.

ftp://videl.ics.hawaii.edu/mirrors/fedora/linux/core/test/2.91/i386/os/Fedora/RPMS/
You can download it from here.

Downgrading would require you to:
1) rpm -qa |grep xorg-x11
Get a list of xorg-x11 packages installed.
2) Download the matching list of packages of the older version.
3) rpm -Uvh xorg-x11*.rpm --oldpackage

Then try both the non-dual and dual config files to see if the
behavior is different.
Comment 4 Mike A. Harris 2004-10-05 06:54:08 EDT
(EE) RADEON(0): Idle timed out, resetting engine...

This suggests it is a DRI/DRM interaction issue.  Try disabling
DRI by uncommenting the dri module load line in the config file.

(yes, the log file indicates DRI was auto-disabled at run time,
but please try this also)
Comment 5 Warren Togami 2004-10-05 06:54:57 EDT
I did try that.  It didn't seem to help.
Comment 6 Mike A. Harris 2004-10-05 06:56:26 EDT
One more thing I should note..   The radeon driver in current
rawhide has not changed in quite some time now, nor has the
X server generally speaking.  If new changes in rawhide caused
this problem to surface, I would suspect the kernel perhaps.

More information is needed to determine anything conclusively
however.
Comment 7 Warren Togami 2004-10-05 06:58:46 EDT
I would suspect kernel too, but it was the same 541 kernel both before
and after.  Will do more testing tomorrow.
Comment 8 Mike A. Harris 2004-10-05 06:59:33 EDT
Ok, please try "noaccel" in the driver section.  If this prevents
the problem, we can experiment with XaaNo options to try to track
down the problem point.  It is possible that perhaps some DRI-only
code isn't protected with appropriate conditionalization perhaps.
Comment 10 Mike A. Harris 2004-10-05 07:20:13 EDT
Warren:

Can you also try a singlehead configuration, with DRI manually
disabled?  I'd like to see if we can rule out dualhead as being
an issue and perhaps tie it to the non-DRI codepaths in the
driver.

TIA
Comment 11 Mike A. Harris 2004-10-05 07:23:56 EDT
Just wanted to state, I'm not quite as suspect of this being a
kernel issue now, as it only seems to occur in the non-DRI path
from what you mention above.

Please attach the X server config also.
Comment 12 Warren Togami 2004-10-06 02:56:21 EDT

*** This bug has been marked as a duplicate of 134766 ***
Comment 13 Red Hat Bugzilla 2006-02-21 14:06:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.