Bug 134766 - (radeon 7000 dual head) VT switch causes lockup
(radeon 7000 dual head) VT switch causes lockup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 134623 134765 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 02:55 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 18:59:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (generated by s-c-display) (3.33 KB, text/plain)
2004-10-06 02:57 EDT, Warren Togami
no flags Details
Xorg.0.log (from above config) (49.67 KB, text/plain)
2004-10-06 02:58 EDT, Warren Togami
no flags Details
xorg.conf with NoAccel (3.37 KB, text/plain)
2004-10-06 03:01 EDT, Warren Togami
no flags Details
Xorg.0.log using above config (49.00 KB, text/plain)
2004-10-06 03:01 EDT, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2004-10-06 02:55:39 EDT
Description of problem:
(This is a followup to Bug #134623 which had incorrect or confusing
info.  Read that bug for more info.)

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100
QY [Radeon 7000/VE] (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc: Unknown device 1b8a
	Flags: stepping, 66Mhz, medium devsel, IRQ 11
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at ec00 [size=256]
	Memory at ff9f0000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at 80000000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

Radeon 7000 running in dual head locks up when switching VT.  Only X
locks up, while it is possible to ssh into the system.  If you do not
switch VT manually, killing and restarting X works fine.
  
Xorg.0.log says the following line repeatedly when X locks up:
(EE) RADEON(0): Idle timed out, resetting engine...

Option "NoAccel" prevents this lockup.  "RenderAccel" "No" does not
prevent this lockup, nor does all XaaNo options when used together. 
DRI does not seem to matter as it DRI is unavailable in dual head.

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=104773&action=view
lspci -v

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-4
Comment 1 Warren Togami 2004-10-06 02:56:34 EDT
*** Bug 134623 has been marked as a duplicate of this bug. ***
Comment 2 Warren Togami 2004-10-06 02:57:34 EDT
Created attachment 104825 [details]
xorg.conf (generated by s-c-display)
Comment 3 Warren Togami 2004-10-06 02:58:53 EDT
Created attachment 104826 [details]
Xorg.0.log (from above config)
Comment 4 Warren Togami 2004-10-06 03:01:20 EDT
Created attachment 104827 [details]
xorg.conf with NoAccel
Comment 5 Warren Togami 2004-10-06 03:01:57 EDT
Created attachment 104828 [details]
Xorg.0.log using above config
Comment 6 Mike A. Harris 2004-10-12 01:12:57 EDT
*** Bug 134765 has been marked as a duplicate of this bug. ***
Comment 7 Mario Becroft 2005-01-11 03:40:24 EST
I have precisely the same problem with my Sony Vaio laptop PCG-C1MAH
with Radeon graphics card. The outfrom from lspci -v is:

00:0c.0 VGA compatible controller: ATI Technologies Inc Radeon
Mobility M6 LY (prog-if 00 [VGA])
        Subsystem: Sony Corporation: Unknown device 80ec
        Flags: bus master, stepping, medium devsel, latency 66, IRQ 9
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 2800 [size=256]
        Memory at e8110000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2

I have tried with Xorg-6.8.1-12 (the original version shipped with
fedora core 3) as well as the updated version 6.8.1-12.FC3.21.

The problem occurs only when using the internal LCD display and the
external VGA output at the same time. The same configuration used to
work fine with XFree86 version 4.3.

I haven't looked at the code yet, but I would love to know how to fix it.
Comment 8 Brian Freeman 2005-01-24 11:06:35 EST
I also seem to have the same issue, however my machine will hang at
startup right after the line, "Starting HAL daemon:   [  OK  ]".  I
can ssh into the machine still, and I haven't seen anything in the
xorg logs that state the problem.  Adding the NoAccel option to the
xorg.conf does work around the issue, but then moving windows around
or scrolling on the notebook LCD is jumpy.  The only work I have is to
boot up with the external display disabled, plug in the external,
change the xorg.conf with sys-config-display and then restore the
backup xorg.conf.  Logout and back in again which enables the dual
head.  However, if I try to switch virtual console, the gui will hang
again.

Here is the output from lspci -v:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
Mobility M7 LW [Radeon Mobility 7500] (prog-if 00 [VGA])
        Subsystem: IBM: Unknown device 0530
        Flags: bus master, stepping, fast Back2Back, 66Mhz, medium
devsel, latency 66, IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [disabled] [size=128M]
        I/O ports at 3000 [disabled] [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [disabled]
[size=64K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
Comment 9 Mike A. Harris 2005-03-06 18:59:03 EST
Should be fixed in rawhide now.  If the problem persists however,
file a bug report in X.Org bugzilla and paste the URL here and
reopen and we'll track it.

TIA
Comment 10 Wouter Buitenhuis 2005-04-03 15:38:04 EDT
Hi, can anyone explain me what rawhide means? Should I install the latest 
fedora test version, or should I at some line to the xorg.conf file? If I need 
the latest test version can anyone give me some pointers how to get this? 
thanks. 
 
(In reply to comment #9) 
> Should be fixed in rawhide now.  If the problem persists however, 
> file a bug report in X.Org bugzilla and paste the URL here and 
> reopen and we'll track it. 
>  
> TIA 
 
 

Note You need to log in before you can comment on or make changes to this bug.