Bug 1346270 - Pool VM loses its disk during reinitialisation after shutdown.
Summary: Pool VM loses its disk during reinitialisation after shutdown.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.1
: 4.0.1
Assignee: Arik
QA Contact: sefi litmanovich
URL:
Whiteboard:
Depends On:
Blocks: 1348950
TreeView+ depends on / blocked
 
Reported: 2016-06-14 12:11 UTC by Roman Hodain
Modified: 2019-11-14 08:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update fixes a race condition that exists during automatic startup of prestarted virtual machines in virtual machine pools and manual operations of virtual machines in the pool. The condition caused virtual machines to lose its disks while being returned to the virtual machine pool.
Clone Of:
: 1346848 1348950 (view as bug list)
Environment:
Last Closed: 2016-08-23 20:42:36 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1743 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0 GA Enhancement (ovirt-engine) 2016-09-02 21:54:01 UTC
oVirt gerrit 59450 0 master MERGED core: prevent removal of all images of prestarted stateless vm 2016-06-23 08:55:08 UTC
oVirt gerrit 59468 0 master MERGED core: acquire vm lock on RestoreStatelessVm 2016-06-23 11:49:30 UTC
oVirt gerrit 59689 0 ovirt-engine-4.0 MERGED core: prevent removal of all images of prestarted stateless vm 2016-06-24 11:52:26 UTC
oVirt gerrit 59690 0 ovirt-engine-4.0 MERGED core: acquire vm lock on RestoreStatelessVm 2016-06-24 14:31:41 UTC

Description Roman Hodain 2016-06-14 12:11:04 UTC
Description of problem:
     When a pool VM is returned to the pull it sometimes loses its disk and cannot be prestarted any more as it does not have any disk.

Version-Release number of selected component (if applicable):
    rhevm-3.6.5.3-0.1.el6.noarch

How reproducible:
    Time to time as this is a race condition.

Steps to Reproduce:
    1. Return a pool VM to the pool exactly in the same time when the VMs are automatically being prestarted. (every VmPoolMonitorIntervalInMinutes)

Actual results:
     Vm loses all disk volumes and is not bale to start any more.

Expected results:
     Vm does not lose the volumes (DestroyImageVDSCommand is not triggered twice)

Comment 9 sefi litmanovich 2016-08-01 13:58:02 UTC
Ran whole vm pools test plan on automation several times, In addition wrote another automated test with a vm pool with all vms set as prestarted, and user allocating vms, then detaching, also allocating and stopping the vms, and a bit of both, all that for around 1 hour.. Did not produce the bug.
Bug didn't re produce at no point.

Verified running with rhevm-4.0.2.3-0.1.el7ev.noarch, all tests passed.

Comment 11 errata-xmlrpc 2016-08-23 20:42:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html


Note You need to log in before you can comment on or make changes to this bug.