Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1346296 - 03-roles.rb seeds katello view_* filters for Viewer role multiple times
Summary: 03-roles.rb seeds katello view_* filters for Viewer role multiple times
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Lukas Pramuk
URL:
Whiteboard:
: 1293456 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-14 13:26 UTC by Lukas Pramuk
Modified: 2019-09-26 14:48 UTC (History)
5 users (show)

Fixed In Version: rubygem-katello-3.0.0.57-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:05:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15427 0 Normal Closed 03-roles.rb seeds katello view_* filters for Viewer role multiple times 2021-01-05 14:30:33 UTC

Description Lukas Pramuk 2016-06-14 13:26:28 UTC
Description of problem:
03-roles.rb seeds katello view_* filters for Viewer role multiple times
On a fresh/upgraded Satellite Viewer role has following filters listed 5 times:
- view_activation_keys
- view_content_hosts
- view_content_views
- view_gpg_keys
- view_host_collections
- view_lifecycle_environments
- view_products
- view_subscriptions
- view_sync_plans

It seems that it was introduced by fix of BZ 1341656

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Navigate to Administer -> Roles -> Viewer -> tab Filters
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none
>>> some filters listed 5 times

2. # foreman-rake db:seed
...
Seeding /usr/share/foreman/db/seeds.d/03-roles.rb
...
All seed files executed

3.Navigate to Administer -> Roles -> Viewer -> tab Filters
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none 	
Activation Keys 	view_activation_keys 		none
>>> some filters listed 6 times

Actual results:
multliplicity of filters

Expected results:
no duplicity

Comment 3 Partha Aji 2016-06-15 17:38:37 UTC
Created redmine issue http://projects.theforeman.org/issues/15427 from this bug

Comment 4 Bryan Kearney 2016-06-15 18:16:35 UTC
Upstream bug component is Content Management

Comment 5 Bryan Kearney 2016-06-16 14:16:21 UTC
Upstream bug component is Provisioning

Comment 6 Bryan Kearney 2016-06-16 22:16:06 UTC
Upstream bug component is Content Management

Comment 7 Bryan Kearney 2016-06-22 18:17:41 UTC
Upstream bug component is Users & Roles

Comment 8 Bryan Kearney 2016-06-29 14:17:40 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15427 has been closed

Comment 9 Lukas Pramuk 2016-07-07 11:40:15 UTC
VERIFIED.

@satellite-6.2.0-19.0.el7sat.noarch
tfm-rubygem-katello-3.0.0.57-1.el7sat.noarch
foreman-1.11.0.43-1.el7sat.noarch

used manual reproducer in comment #0:

1. Navigate to Administer -> Roles -> Viewer -> tab Filters
>>> each filter is listed only once 

2. # foreman-rake db:seed
...
Seeding /usr/share/foreman/db/seeds.d/03-roles.rb
...
All seed files executed

3.Navigate to Administer -> Roles -> Viewer -> tab Filters
>>> each filter is still listed only once

Comment 10 Bryan Kearney 2016-07-27 11:05:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Comment 11 Marek Hulan 2016-09-05 13:55:26 UTC
*** Bug 1293456 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.