Bug 134649 - [patch]Custom hyphens doesn't work anymore
[patch]Custom hyphens doesn't work anymore
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 140247 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 09:20 EDT by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 07:44:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to alias the two different - buttons as the same (803 bytes, patch)
2004-12-15 10:41 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Daniel Malmgren 2004-10-05 09:20:35 EDT
Description of problem:
Pressing CTRL and - buttons on my keyboard no longer produces custom
(soft) hyphens as it used to, instead an ordinary hard hyphen is
produced. It also seems like custom hyphens in opened documents (which
has worked before) are converted to hard hyphens.

Version-Release number of selected component (if applicable):
1.1.2-7

Additional info:
I don't exactly know when it stopped working, all I know for sure is
that it worked in earlier 1.1.2 versions.
Comment 1 Caolan McNamara 2004-12-15 08:21:57 EST
I see it as well, its related to the gtk integration. (also logged
upstream as http://www.openoffice.org/issues/show_bug.cgi?id=39038)
Comment 2 Caolan McNamara 2004-12-15 10:41:22 EST
Created attachment 108620 [details]
patch to alias the two different - buttons as the same

caolanm->dcbw: something odd here. The generic non-vcl vcl-plug appearently
sees the - from the top row and the - from the numeric keypad as the same
keysym. This patch makes the top row - act the same as the keypad one from the
gtk plugin as well.
Comment 3 Caolan McNamara 2004-12-15 10:43:25 EST
cmc->Daniel: You can use ctrl + the "-" from the numberic keypad as a
workaround to get custom hyphens for the moment
Comment 4 Caolan McNamara 2004-12-15 10:53:13 EST
*** Bug 140247 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Malmgren 2004-12-15 13:41:16 EST
caolan: Thanks. Can't really understand why I didn't try that myself...
Comment 6 Caolan McNamara 2005-01-27 07:44:06 EST
fixed in 1.1.3 as available in rawhide and fc3-updates.
integrated in upstream 2.0

Note You need to log in before you can comment on or make changes to this bug.