Bug 1346752 - REST-API V3 | Failed to update VM disk bootable flag
Summary: REST-API V3 | Failed to update VM disk bootable flag
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.0.0-rc2
: ---
Assignee: Tal Nisan
QA Contact: Carlos Mestre González
URL:
Whiteboard:
: 1346887 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 09:56 UTC by Meni Yakove
Modified: 2016-07-05 08:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 08:03:23 UTC
oVirt Team: Storage
rule-engine: ovirt-4.0.0+
rule-engine: blocker+
rule-engine: planning_ack+
amureini: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine log (173.60 KB, application/zip)
2016-06-15 09:56 UTC, Meni Yakove
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 57738 0 master MERGED restapi: Use interface and boot values in old API if provided 2016-06-15 16:40:39 UTC
oVirt gerrit 59244 0 master MERGED restapi: Use existing DiskAttachment entity when editing a VM disk 2016-06-15 16:40:33 UTC
oVirt gerrit 59261 0 ovirt-engine-4.0 MERGED restapi: Use existing DiskAttachment entity when editing a VM disk 2016-06-15 16:43:12 UTC
oVirt gerrit 59262 0 ovirt-engine-4.0 MERGED restapi: Use interface and boot values in old API if provided 2016-06-15 16:43:00 UTC

Description Meni Yakove 2016-06-15 09:56:55 UTC
Created attachment 1168298 [details]
engine log

Description of problem:
Failed to update VM disk bootable flag with error:

<fault>
<reason>Operation Failed</reason>
<detail>[Interface is required]</detail>
</fault>

Same error when sending:
<disk>
  <bootable>true</bootable>
  <interface>virtIO</interface>
</disk>



Version-Release number of selected component (if applicable):
rhevm-4.0.0.4-0.1.el7ev.noarch


Steps to Reproduce:
1. send PUT to ovirt-engine/api/vms/<vm_id>/disks/<disk_id>:
<disk>
  <bootable>true</bootable>
</disk


2016-06-15 12:44:31,181 WARN  [org.ovirt.engine.core.bll.storage.disk.UpdateVmDiskCommand] (default task-32) [6f42f4f5] Validation of action 'UpdateVmDisk' failed for user admin@internal-aut
hz. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__DISK,VALIDATION_DISK_INTERFACE_NOT_NULL
2016-06-15 12:44:31,183 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (default task-32) [] Operation Failed: [Interface is required]

Comment 1 Red Hat Bugzilla Rules Engine 2016-06-15 10:20:56 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Juan Hernández 2016-06-15 14:57:05 UTC
*** Bug 1346887 has been marked as a duplicate of this bug. ***

Comment 3 sefi litmanovich 2016-06-15 14:58:29 UTC
*** Bug 1346887 has been marked as a duplicate of this bug. ***

Comment 4 Allon Mureinik 2016-06-20 12:59:01 UTC
This is included in ovirt-engine-4.0.0.5

Comment 5 Carlos Mestre González 2016-06-22 15:50:25 UTC
verified on rhevm-4.0.0.6-0.1.el7ev.noarch

Comment 6 Carlos Mestre González 2016-06-23 18:13:10 UTC
Back to assigned, this is broken.

Changing a disk to virtio or ide works, but it fails with virtio_scsi with:

<fault>
<detail>[Interface is required]</detail>
<reason>Operation Failed</reason>
</fault>

on the WebUI works fine to change the disk interface to virtio scsi.

Comment 7 Red Hat Bugzilla Rules Engine 2016-06-23 18:13:16 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 8 Carlos Mestre González 2016-06-23 18:14:47 UTC
My mistake, The bootable flag works any way, but there's an issue when changing the interface for virtio_scsi. 

Tal, should I open a new bug or keep this as assigned since the error could be the same issue?

Comment 9 Red Hat Bugzilla Rules Engine 2016-06-23 18:14:53 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 10 Carlos Mestre González 2016-06-23 18:27:33 UTC
Sorry for all the comments, open a new bug with this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1349594

Comment 11 Sandro Bonazzola 2016-07-05 08:03:23 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.