Bug 1349594 - REST-API v3 | Failed to update VM disk interface to virtio_scsi
Summary: REST-API v3 | Failed to update VM disk interface to virtio_scsi
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.0.1
: 4.0.1.1
Assignee: Juan Hernández
QA Contact: Carlos Mestre González
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 18:26 UTC by Carlos Mestre González
Modified: 2016-07-19 06:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 06:24:57 UTC
oVirt Team: Storage
rule-engine: ovirt-4.0.z+
rule-engine: planning_ack+
juan.hernandez: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 59730 0 master MERGED restapi: Map correctly disk interface types 2016-06-27 09:57:24 UTC
oVirt gerrit 59731 0 master MERGED restapi: Always populate V3 disk interface and bootable 2016-06-27 09:57:43 UTC
oVirt gerrit 59808 0 ovirt-engine-4.0 MERGED restapi: Map correctly disk interface types 2016-06-27 10:34:18 UTC
oVirt gerrit 59809 0 ovirt-engine-4.0 MERGED restapi: Always populate V3 disk interface and bootable 2016-06-28 12:15:13 UTC

Description Carlos Mestre González 2016-06-23 18:26:51 UTC
Description of problem:
Send PUT to /vms/{vm:id}/disks/{disk:id} with:

<disk><interface>virtio_scsi</interface></disk>

fails with: 
<fault>
<detail>[Interface is required]</detail>
<reason>Operation Failed</reason>
</fault>

doesn't fail with other types (ide, virtio) or changing it via the WebUI.

Version-Release number of selected component (if applicable):
rhevm-4.0.0.6-0.1.el7ev.noarch

How reproducible:
100%

Additional info:
Discovered while working on https://bugzilla.redhat.com/show_bug.cgi?id=1346752 (and the error is the same, maybe related)

Comment 1 Juan Hernández 2016-06-24 09:16:37 UTC
This happens because we are assuming that the disk interface types used by the backend are exactly the same used by the API. But that isn't true. The proposed patch fixes that.

In addition, the disk interface and bootable flags aren't reported correctly when a disk is added or updated. That is also fixed by one of the proposed patches.

Comment 2 Carlos Mestre González 2016-07-07 10:55:19 UTC
rhevm-4.0.2-0.2.rc1.el7ev.noarch

Comment 3 Sandro Bonazzola 2016-07-19 06:24:57 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/


Note You need to log in before you can comment on or make changes to this bug.