Bug 134687 - hal-cups-utils should BuildRequires: gtk2-devel
hal-cups-utils should BuildRequires: gtk2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal-cups-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 11:56 EDT by Maxim Dziumanenko
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 16:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2004-10-05 11:56:15 EDT
Description of problem:
gtk2-headers headers and development libs needed to build hal-cups-utils

Version-Release number of selected component (if applicable):
hal-cups-utils-0.5.2-3

How reproducible:
Always

Steps to Reproduce:
1.rpm -e gtk2-devel
2.rpmbuild -ba hal-cups-utils-0.5.2-3.src.rpm
3.Wait for build error
  
Actual results:


Expected results:


Additional info:
Comment 1 John (J5) Palmieri 2004-10-05 12:00:59 EDT
hal-cups-utils doesn't use gtk at all.  It uses glib.  Please attach
the error output.
Comment 2 Maxim Dziumanenko 2004-10-06 09:06:13 EDT
checking for glib-2.0 >= 2.4
                         gobject-2.0 >= 2.4
                         gdk-2.0 >= 2.4
                        ... Package gdk-2.0 was not found in the
pkg-config search path.
Perhaps you should add the directory containing `gdk-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gdk-2.0' found

configure: error: Library requirements (glib-2.0 >= 2.4
                         gobject-2.0 >= 2.4
                         gdk-2.0 >= 2.4
                        ) not met; consider adjusting the
PKG_CONFIG_PATH environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.8569 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.8569 (%build)
Comment 3 John (J5) Palmieri 2004-10-06 16:57:06 EDT
Added patch to remove gdk from the configure.in.  hal-cups-utils will
not require gtk to build anymore.  Fixed in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.