Bug 1347053 - Audacity UI has rendering glitches
Summary: Audacity UI has rendering glitches
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity   
(Show other bugs)
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 22:51 UTC by Sam Thursfield
Modified: 2016-11-24 20:27 UTC (History)
20 users (show)

Fixed In Version: audacity-2.1.3-0.7.20161109git53a5c93.fc25 audacity-2.1.3-0.7.20161109git53a5c93.fc24
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-24 16:28:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the problem (42.28 KB, image/png)
2016-09-01 13:57 UTC, Sam Thursfield
no flags Details

Description Sam Thursfield 2016-06-15 22:51:31 UTC
Buttons randomly disappear in the Audacity UI when I move the mouse over them.

This happens whenever I run Audacity.

I see many of the following two errors on the console:

(audacity:10124): Gdk-CRITICAL **: gdk_window_get_origin: assertion 'GDK_IS_WINDOW (window)' failed

*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

Comment 1 rickw 2016-07-13 01:00:22 UTC
This issue was solved for me a few minutes ago with the latest f24 dnf updates.
The error message in the original report seems to be a red herring.

Comment 2 rickw 2016-07-13 02:38:44 UTC
Crazy! I spoke too soon. Problem persists, after the updates even though I though it had been fixed. This is a particularly difficult problem to describe given the bizzare behavior of the buttons disappearing in the interface. It seems like only "energised" buttons disappear on a mouseover. The invisible buttons still function (if you can hit them).  How can I help?

Comment 3 Joshua Bowren 2016-07-13 19:38:27 UTC
I also experience this bug. Reproducible with a fresh install of Fedora 24.

Comment 4 rickw 2016-07-13 21:09:49 UTC
I noticed this problem right away after upgrading to f24. I was running a local binary that I had compiled from source on f23. I then uninstalled my local binary and installed audacity from the f24 repo, same problem. Then I uninstalled and installed audacity-freeworld from rpm fusion, same problem. Then I recompiled the source on f24, same problem.

I don't believe this is likely an audacity problem, per se, but one of the gui rendering packages that audacity uses to present the interface.  Whether an update caught audacity "getting away with" something in the rendering, or whether there is a problem in the rendering engine(s) remains to be seen. I wish I knew enough to be helpful...

Work around, and further hint... dragging the troublesome toolbar elements off the main window seems to be effective in getting them to work properly, and I'm beginning to like using them that way!!

Comment 5 Andrea 2016-07-16 09:36:39 UTC
If +1 comments are useful, this is mine.

Fully updated Fedora 24 on x64 on default GNOME desktop.

Simply dragging the window off and on the screen does not recover the buttons for me.

A maximize + unmaximize (or the other way round) fixes it temporarily.

Comment 6 Roman C 2016-07-22 14:23:03 UTC
Same here.

Comment 7 Nunes 2016-08-12 11:48:06 UTC
Compiling Audacity 2.1.1 from source doesn't exhibit these glitches. This version is the last one to use the GTK2 port of wxWidgets.

I'd suspect this bug is a regression caused by wxGTK3, as I have experienced similar issues in another wxGTK3 application regarding double-buffered drawing.

Comment 8 David Timms 2016-08-25 21:37:43 UTC
Which app has that issue ?
Is the issue now fixed in that app ?

Comment 9 Nunes 2016-08-25 23:14:25 UTC
The app is "spek". There is a report with a workaround described here: https://github.com/alexkay/spek/issues/106

Comment 10 Sam Thursfield 2016-09-01 13:57 UTC
Created attachment 1196851 [details]
Screenshot of the problem

Comment 11 Sam Thursfield 2016-09-01 14:11:33 UTC
Seems that only Audacity developers can open bugs on http://bugzilla.audacityteam.org/ so I've notified the Audacity developers by email about this issue

Comment 12 Sam Thursfield 2016-09-01 14:58:06 UTC
Thanks Nunes for the link to the Spek issue. I tried changing calls to wxAutoBufferedPaintDCFactory to just use wxBufferedPaintDC, but no luck. That function is only called in a few widgets: widgets/ASlider.cpp, widgets/Meter.cpp and somewhere in the LV2 plugin code. So it makes sense that it doesn't affect toolbar drawing. Worth a try though :-)

So, the issue is still present as of Audacity commit 6881163129c35852012bb6651cc7c88aed2465ca (31st Aug 2016).

Comment 13 Sam Thursfield 2016-09-04 23:59:45 UTC
Part of the response from the Audacity project was this:

> There isn't a problem with this on Ubuntu or Debian as far as I am
> aware.

> One test you could make would be to build Audacity against the
> standard wxWidgets 3.0.2 from
> https://github.com/wxWidgets/wxWidgets/releases/download/v3.0.2/wxWidgets-> 3.0.2.tar.bz2
> .

> Also are you or Fedora configuring wxWidgets with
>
> --with-gtk=3  ?

> If so, that is not officially supported by Audacity:
> http://www.audacityteam.org/download/source/#instructions .

Looking at the .spec file for wxGTK3 in Fedora 24...

http://pkgs.fedoraproject.org/cgit/rpms/wxGTK3.git/tree/wxGTK3.spec?h=f24

...it seems likely that we are indeed configuring wxGTK with --with-gtk=3

Comment 14 pkoz 2016-09-11 11:44:19 UTC
(In reply to rickw from comment #4)
> I noticed this problem right away after upgrading to f24. I was running a
> local binary that I had compiled from source on f23. I then uninstalled my
> local binary and installed audacity from the f24 repo, same problem. Then I
> uninstalled and installed audacity-freeworld from rpm fusion, same problem.
> Then I recompiled the source on f24, same problem.
> 
> I don't believe this is likely an audacity problem, per se, but one of the
> gui rendering packages that audacity uses to present the interface.  Whether
> an update caught audacity "getting away with" something in the rendering, or
> whether there is a problem in the rendering engine(s) remains to be seen. I
> wish I knew enough to be helpful...
> 
> Work around, and further hint... dragging the troublesome toolbar elements
> off the main window seems to be effective in getting them to work properly,
> and I'm beginning to like using them that way!!

Another workaround until the wxGTK3 issue is solved might be this, which has been working for me some time:

After startup, resize the Audacity window by dragging its right edge first to the left till the toolbars rearrange themselves, then back to the original size. After that the toolbar controls become stable.

Comment 15 Michael Schwendt 2016-09-26 18:20:34 UTC
Same here. Audacity suffers from disappearing widgets.

Logged out of GNOME, then into Openbox, and Audacity starts with an empty window and an almost completely non-functional GUI.

Comment 16 Franco Comida 2016-10-02 19:01:40 UTC
Same problem with wxMaxima on f24, I can't remember this issue affected both programs in f23.

Comment 17 Alexander 2016-10-23 09:46:25 UTC
Same here.
Any solution or rebuilt packages?

Comment 18 Andy Holmes 2016-10-24 10:17:49 UTC
This indeed is not limited to Audacity, and definitely appears to be a bug with wxGTK3 when compiled with Gtk3. I encountered this compiling a trunk version of gspiceui that compiled fine on Ubuntu.

After reading this bug report I removed wxGTK3-devel, installed compat-wxGTK3-gtk2 and compat-wxGTK3-gtk2-devel and recompiled to find the graphical glitches solved. I can only assume Ubuntu is still compiling wxGTK3 with Gtk2.

Comment 19 Andy Holmes 2016-10-24 10:21:39 UTC
Sorry, should have pointed out I'm running Fedora 25 so the bug definitely still exists.

Comment 20 Franco Comida 2016-10-24 15:57:58 UTC
I can confirm rebuildig audacity with compat-wxGTK3-gtk2 solve the issue in f24. Had troubles rebuilding wxMaxima, its configure doesn't like compat-wxGTK3-gtk2, it needs to be patched.22

Comment 21 David Timms 2016-10-25 12:01:10 UTC
I also maintain the copr builds. I've done a Audacity -git head pull, and tried a few attempts at building with compat-wxGTK3-gtk2:
https://copr.fedorainfracloud.org/coprs/dtimms/audacity-git/builds/

, but it doesn't succeed in mock, so I don't think will succeed there either.

I'm currently have installed both:
compat-wxGTK3-gtk2-devel-3.0.2-7.fc24.x86_64
wxGTK3-devel-3.1.0-0.1.fc24.x86_64

, and can rpmbuild -ba with either. However, neither rpm resolves the failure to draw parts of the toolbar (especially around the transport buttons). Running F24 with Wayland (I think).

I also get Dialog boxes for assertions, which are rather annoying to click through. I haven't investigated the cause of these.

Comment 22 Franco Comida 2016-10-27 22:23:05 UTC
David Timms: 
checking for wx-config... no
checking for wx-config-3.0... no
configure: error: Could not find wx-config: is wxWidgets installed? is wx-config in your path?

You must use alternatives to make wx-config-3.0 (which is actually missing) to point to the right one.

alternatives --install /usr/bin/wx-config-3.0 wx-config-3.0 /usr/bin/wx-config-3.0-gtk2 1

I guess you can put it into your SPECFILE or alternatively there should be an --wx-config-path= to set to /usr/bin/wx-config-3.0-gtk2

Comment 23 Rob 2016-11-02 01:47:17 UTC
Regarding the fix by resizing the window immediately after startup:

this seems to work, as the buttons do not vanish when hovering over them, but as soon as I start doing real work, the bad button behavior happens again.

So my conclusion: this is only temporary cosmetic fix; not a fix for a production environment.

R.

Comment 24 Fedora Update System 2016-11-10 12:34:19 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-99f8d418ba

Comment 25 Fedora Update System 2016-11-10 12:35:36 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f35f35613

Comment 26 Steven A. Falco 2016-11-10 13:04:15 UTC
I just tried audacity-2.1.3-0.7.20161109git53a5c93.fc24 and the buttons are now stable for me.  Good job.

Comment 27 Fedora Update System 2016-11-10 19:27:45 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-99f8d418ba

Comment 28 David H. Gutteridge 2016-11-10 21:09:40 UTC
I cannot duplicate this problem with audacity-2.1.3-0.7.20161109git53a5c93. (And I was definitely seeing it with the previous version.)

Comment 29 David Timms 2016-11-10 21:12:29 UTC
(In reply to Franco Comida from comment #22)
> David Timms: 
> checking for wx-config... no
> checking for wx-config-3.0... no
> configure: error: Could not find wx-config: is wxWidgets installed? is
> wx-config in your path?
> 
> You must use alternatives to make wx-config-3.0 (which is actually missing)
> to point to the right one.
> 
> alternatives --install /usr/bin/wx-config-3.0 wx-config-3.0
> /usr/bin/wx-config-3.0-gtk2 1
During package build, the commands in the .spec do not have root access, and hence can't run the alternatives command.

> I guess you can put it into your SPECFILE or alternatively there should be
> an --wx-config-path= to set to /usr/bin/wx-config-3.0-gtk2
There is something similar. And with another trick I've been able to have Audacity using wxGTK3 -gtk2 to build in mock (how packages are built for Fedora and RPM Fusion).

(In reply to Steven A. Falco from comment #26)
> I just tried audacity-2.1.3-0.7.20161109git53a5c93.fc24 and the buttons are
> now stable for me.  Good job.

(In reply to David H. Gutteridge from comment #28)
> I cannot duplicate this problem with audacity-2.1.3-0.7.20161109git53a5c93.
> (And I was definitely seeing it with the previous version.)

Excellent, thanks for the reports. Do you know if your machines are using Wayland ?

Comment 30 David H. Gutteridge 2016-11-10 21:32:25 UTC
(In reply to David Timms from comment #29)
> (In reply to David H. Gutteridge from comment #28)
> > I cannot duplicate this problem with audacity-2.1.3-0.7.20161109git53a5c93.
> > (And I was definitely seeing it with the previous version.)
> 
> Excellent, thanks for the reports. Do you know if your machines are using
> Wayland ?

I'm using X11. I haven't tested under Wayland.

Comment 31 Fedora Update System 2016-11-11 05:02:38 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f35f35613

Comment 32 Steven A. Falco 2016-11-11 13:17:09 UTC
I too am using X11.

Comment 33 Fedora Update System 2016-11-24 16:28:03 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2016-11-24 20:27:09 UTC
audacity-2.1.3-0.7.20161109git53a5c93.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.