Bug 134726 - unable to startx
unable to startx
Status: CLOSED DUPLICATE of bug 134673
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2004-10-05 15:34 EDT by Scott Talbot
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Scott Talbot 2004-10-05 15:34:44 EDT
Description of problem:
system cannot log into any account in runlevel 5

Version-Release number of selected component (if applicable):

How reproducible:
always either from graphical session chooser or startx

Steps to Reproduce:
1.boot to run level 5
2.attempt to log into any account
Actual results:
warning message that session has lasted less thatn 10 seconds

Expected results:
Xscreen with gnome background
(error messages if using startx method)
Additional info:

bug is fixed by adding a 'fi' to the unmatched pair in

# check to see if the user has a preferred desktop
if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
    elif [ "$DESKTOP" = "KDE" ]; then
Comment 1 Andrew Farris 2004-10-05 16:37:47 EDT
duplicate of #134673 and #134711
Comment 2 Scott Talbot 2004-10-05 23:06:07 EDT

*** This bug has been marked as a duplicate of 134673 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.