Bug 134761 - Syntax error in /etc/X11/xinit/Xclients cause gnome session to fail
Syntax error in /etc/X11/xinit/Xclients cause gnome session to fail
Status: CLOSED DUPLICATE of bug 134673
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 01:55 EDT by David Lawrence
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2004-10-06 01:55:38 EDT
Description of problem:
Missing 'fi' in Xclients

# check to see if the user has a preferred desktop
PREFERRED=
if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED=startkde
fi

should be

# check to see if the user has a preferred desktop
PREFERRED=
if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED=startkde
    fi
fi

Version-Release number of selected component (if applicable):
xinitrc-4.0.7-1
Comment 1 Bryan W Clark 2004-10-06 08:51:35 EDT
Yellow Pad bug
Comment 2 Mike A. Harris 2004-10-06 08:52:09 EDT
*** This bug has been marked as a duplicate of 134673 ***

*** This bug has been marked as a duplicate of 134673 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.