Bug 134783 - evolution says We were unable to open this addressbook.
evolution says We were unable to open this addressbook.
Status: CLOSED DUPLICATE of bug 135483
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
http://bugzilla.ximian.com/show_bug.c...
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-06 05:24 EDT by taj
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description taj 2004-10-06 05:24:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20040930

Description of problem:
glibc-2.3.3-63.x86_64
evolution-connector-2.0.1-5.x86_64
evolution-data-server-1.0.1-1.i386
glibc-common-2.3.3-63.x86_64
glibc-kernheaders-2.4-9.1.87.x86_64
evolution-data-server-1.0.1-1.x86_64
glibc-profile-2.3.3-63.x86_64
glibc-2.3.3-63.i686
glibc-headers-2.3.3-63.x86_64
glibc-utils-2.3.3-63.x86_64
evolution-devel-2.0.1-2.x86_64
evolution-webcal-1.0.10-1.x86_64
glibc-devel-2.3.3-63.x86_64
evolution-2.0.1-2.x86_64


There appear to be missing x86_64 fixes.  Please see URL and confirm
they get into fedora-devel.

The same bug appears in current fedora-devel for x86-64.

Version-Release number of selected component (if applicable):
evolution-data-server-1.0.1-1.x86_64

How reproducible:
Always

Steps to Reproduce:
1.  Install evolution* on x86-64
2.  create new account and log in
3.  start evolution

click on contacts
    

Actual Results:  [tevo@www ~]$ evolution
asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'
asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'
impl_GNOME_Evolution_Addressbook_BookFactory_getBook
impl_GNOME_Evolution_Addressbook_Book_open (0x58fb50)
in server_log_handler

(evolution-data-server:28760): libebookbackend-WARNING **: libdb
error: environment not yet opened
in server_log_handler

(evolution-data-server:28760): libebookbackend-WARNING **: libdb
error: environment not yet opened
in server_log_handler

(evolution-data-server:28760): libebookbackend-WARNING **: libdb
error: environment not yet opened
in server_log_handler

(evolution-data-server:28760): libebookbackend-WARNING **: db->open
(... DB_CREATE ...) failed with 22
loading error file
/usr/share/evolution/2.0/errors/mail-composer-errors.xml
loading error file /usr/share/evolution/2.0/errors/addressbook-errors.xml
loading error file /usr/share/evolution/2.0/errors/calendar-errors.xml
loading error file /usr/share/evolution/2.0/errors/e-system-errors.xml
loading error file /usr/share/evolution/2.0/errors/filter-errors.xml
loading error file /usr/share/evolution/2.0/errors/shell-errors.xml
loading error file /usr/share/evolution/2.0/errors/mail-errors.xml

(evolution:28865): eab-widgets-CRITICAL **: file e-addressbook-view.c:
line 1861 (eab_view_discard_menus): assertion `view->view_instance' failed

(evolution:28865): eab-widgets-CRITICAL **: file e-addressbook-view.c:
line 1861 (eab_view_discard_menus): assertion `view->view_instance' failed

(evolution:28865): eab-widgets-CRITICAL **: file e-addressbook-view.c:
line 1861 (eab_view_discard_menus): assertion `view->view_instance' failed


Expected Results:  

view contacts

Additional info:



Suspected fix upstream (again?), please confirm it gets in.  See url.

This just recently started happening while continuing to follow
fedora-devel.  Previous versions did not exhibit the problem.
Comment 1 taj 2004-10-07 00:51:42 EDT
For users that found this bug you can do:

rpm -e evolution-data-server-1.0.1-1.i386
evolution-data-server-1.0.1-1.x86_64 --nodep

rpm -Uvh evolution-data-server-1.0.0-2.*

[ie downgrade to 1.0.0-2]

then as a user:

evolution --force-shutdown

The contacts will work then.

Older RPMS in case you dont have a copy:

ftp://ftp.qbang.org/pub/evolution-data-server-1.0.0-2.i386.rpm
ftp://ftp.qbang.org/pub/evolution-data-server-1.0.0-2.x86_64.rpm

[will remove when a fix is in fedora-devel]

See also:

http://bugzilla.ximian.com/show_bug.cgi?id=67600
http://bugzilla.ximian.com/show_bug.cgi?id=65996

And probably man more :)
Comment 2 taj 2004-10-14 01:15:43 EDT
evolution-data-server-1.0.2-2 appears to have a fix.  Contacts are
working with it.  If nobody else does, I'll close this bug next
release after confirming it does not go away again :)
Comment 3 Dave Malcolm 2004-10-14 10:21:24 EDT
Thanks, this looks like a duplicate of bug #135483.  It's good to have
confirmation that this is working again on x86_64

*** This bug has been marked as a duplicate of 135483 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.