Bug 135483 - Error Loading Addressbook; Unable To Add Contacts
Error Loading Addressbook; Unable To Add Contacts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 134783 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 19:29 EDT by Bob Cochran
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 16:37:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Cochran 2004-10-12 19:29:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20040930

Description of problem:
Cannot add a contact to the Evolution "Contacts" panel. I believe that
at first, if I clicked the Contacts button, I would get this error
dialog box:

"Error loading addressbook
We were unable to open this addressbook. Please check that the path
exists and that you have permission to access it."

Clicking "OK" on the above dialog displays an empty contacts panel.
When I clock the "New" button to add a contact, nothing happens.

Suppose I quit evolution while in this panel. When I next restart
evolution, the error message listed above will show up. 

Now, I beleive I can click the "Contacts" button and an empty contacts
panel will show up (without an error message.) But if I quit
evolution, and restart it, I will get the error message shown above.

Suppose I am reading an email, and I want to add the sender to my
Contacts list. I right-click on the sender's email address, and a
small "Add to contacts" window pops up. The window is functional and
appears to be busy adding the email address to the contacts list. But
when I click Contacts to check the contacts list for this contact, all
I get is an empty list with no entries.



Version-Release number of selected component (if applicable):
2.0.1-4

How reproducible:
Always

Steps to Reproduce:
1. Start Evolution
2. Click Contacts button.
3. Error message will show up as described above (in early versions of
evolution for FC3T2 for this architecture.)

or

1. Start Evolution
2. Click "Contacts" button.
3. Contacts list is empty, and you cannot add a new contact my
clicking the "New" button.
4. Quit evolution and restart it.
5. Error message as described above will appear.    

Actual Results:  Error messages, inability to add contacts.

Expected Results:  I should be able to add contacts normally to the
Addressbook and view my Contacts list.

Additional info:
Comment 1 Dave Malcolm 2004-10-13 12:35:00 EDT
This looks like this x86_64 bug for evolution-data-server filed upstream:
http://bugzilla.ximian.com/show_bug.cgi?id=67600

An attempt to fix this is available in Rawhide in the
evolution-data-server-1.0.2-2 package.  Please can you yum update this
package and report if it works with this latest version?
Comment 2 Zack Cerza 2004-10-13 15:28:51 EDT
My x86_64 can add contacts with evolution-data-server-1.0.2-2 (both
archs installed).
Comment 3 Dave Malcolm 2004-10-14 10:21:25 EDT
*** Bug 134783 has been marked as a duplicate of this bug. ***
Comment 4 taj 2004-10-14 10:56:48 EDT

Raised eyebrow.  Marked 134783 a duplicate of the newer 135483 post
and the same solution was later posted there?

There are no politics in bugzilla, right?
Comment 5 Dave Malcolm 2004-10-14 13:22:20 EDT
Eh?  Not as far as I know.  The ordering was purely the order in which
I happened to open the bugzilla emails in my Evolution.

There is no conspiracy (apart from the Swedish one;
ftp://ftp.gnome.org/conspiracy/index.html)
Comment 6 Bob Cochran 2004-10-14 16:08:40 EDT
Yes, evolution-data-server-1.0.2-2 allows me to add contacts now in te
x86_64 architecture. Cool. Thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.