Bug 134785 (xinitrc-common) - Xsession can't find xinitrc-common
Summary: Xsession can't find xinitrc-common
Status: CLOSED RAWHIDE
Alias: xinitrc-common
Product: Fedora
Classification: Fedora
Component: xinitrc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-10-06 09:36 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 15:29:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2004-10-06 09:36:12 UTC
Description of problem:
xinitrc-4.0.10-1 no longer runs the necessary scripts for IIIMF input
to work when logged into CJKI, or when ~/xinput.d/ is configured in a
non-CJKI language.

Version-Release number of selected component (if applicable):
xinitrc-4.0.10-1

Comment 1 Jens Petersen 2004-10-06 10:53:49 UTC
/etc/X11/xdm/Xsession: line 40: ../xinit/xinitrc-common: No such file
or directory

Comment 2 Jens Petersen 2004-10-06 11:00:24 UTC
Using an absolute path to xinitrc-common in Xession fixes
the problem afaict.

Comment 3 Mike A. Harris 2004-10-06 13:00:51 UTC
Thanks guys.  Fixed in 4.0.11-1 by changing to an absolute
path.

Comment 4 Mike A. Harris 2004-10-06 15:29:43 UTC
2 more bugs were found and fixed.

1) ssh-agent support was broken in Xsession, due to inconsistencies
   in the original implementation which surfaced a bug

2) xinitrc had the same bug as reported in this report.

Both bugs fixed in 4.0.13-1 now.

Setting status to "RAWHIDE"


Note You need to log in before you can comment on or make changes to this bug.