Bug 134801 - No mozilla menu entry for KDE
No mozilla menu entry for KDE
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan W Clark
:
: 135852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 09:47 EDT by Phil Schaffner
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 13:34:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil Schaffner 2004-10-06 09:47:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040930

Description of problem:
No entry for Mozilla appears on the KDE applications menu.  Firefox,
Konqueror, and Epiphany are on the RedHat/Internet menu.

Version-Release number of selected component (if applicable):
mozilla-1.7.3-11

How reproducible:
Always

Steps to Reproduce:
1. Look for Mozilla in KDE Appliactions Menu
2.
3.
    

Actual Results:  Not found.

Expected Results:  Mozilla should appear on menu.

Additional info:
Comment 1 Jim Cornette 2004-10-10 17:45:45 EDT
There is no mozilla selection via GNOME either. It is possible to
create a desktop launcher and moving this to the panel for launching
mozilla. This is inconvienient though.
Comment 2 Bill Nottingham 2004-10-15 15:42:21 EDT
*** Bug 135852 has been marked as a duplicate of this bug. ***
Comment 3 Carwyn Edwards 2004-10-24 11:45:35 EDT
I also have missing Mozilla menu entries as well as Evolution. This is
on an FC2 -> FC3t3 update with update to rawhide.

mozilla-1.7.3-17
evolution-2.0.2-1

Note that this is in Gnome not KDE too.
Comment 4 Colin Walters 2004-10-27 20:15:16 EDT
I believe this was done because Firefox depended on Mozilla at some
point.  We didn't want two web browers in the menu.  But I think we
can remove Mozilla from the default install, and remove the NoDisplay
line for FC4.
Comment 5 Christopher Aillon 2004-10-28 00:57:34 EDT
Firefox never depended on Mozilla.  Epiphany did (still does), and so
does evolution, so we need to keep Mozilla around for now.
Comment 6 Phil Schaffner 2004-11-10 14:54:23 EST
I understand the cluttered menu issue, but still would advococate
having Mozilla show up on the menu if it is installed.  [OT: Can
always add it, but (recent, e.g. FC2) past problems with menu editing
make me and others somewhat leary of messing with KDE menus.  Have had
whole categories dissappear when trying to add/delete a single item,
as well as duplicate entries that are difficult to get rid of.]
Comment 7 Christopher Blizzard 2004-11-29 14:06:01 EST
-> over to the clark
Comment 8 Bryan W Clark 2004-12-13 13:34:54 EST
Hi, thanks for the bug report.  Mozilla got the shaft in this release
because of menu clutter, evo and ephy depend on it so we needed it
installed on every desktop but don't want the launcher showing up
since it is essentially deprecated from the distribution.

Firefox can do everything that Mozilla did and more, it will import
old settings and bookmarks so the transition should be a smooth one. 
As evo and epiphany move away from using the Mozilla libraries
(epiphany already uses the firefox libraries) we will be able to allow
the desktop entry to show since the package won't be a required
dependency.

Not sure about KDE menu problems, but it's probably a world better
than GNOME's ;-)

Note You need to log in before you can comment on or make changes to this bug.