Bug 1348115 - MTU setup on qr router legs sometimes does not take effect
Summary: MTU setup on qr router legs sometimes does not take effect
Keywords:
Status: CLOSED DUPLICATE of bug 1365622
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: async
: 9.0 (Mitaka)
Assignee: Ihar Hrachyshka
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks: 1348116
TreeView+ depends on / blocked
 
Reported: 2016-06-20 08:18 UTC by Ihar Hrachyshka
Modified: 2016-08-10 07:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1348116 (view as bug list)
Environment:
Last Closed: 2016-08-10 07:58:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 327651 None MERGED ovs: set device MTU after it's moved into a namespace 2020-09-08 12:18:06 UTC

Description Ihar Hrachyshka 2016-06-20 08:18:53 UTC
Description of problem: in Mitaka, there is a new MTU logic in place, where network calculated MTU is applied to all ports belonging to the network, including router legs and TAP devices.

It was revealed in upstream that the logic does not work for OVS in some cases, when there are ports that belong to networks with different MTUs. In which case MTU setup may not take effect.


Version-Release number of selected component (if applicable): this does not affect any current OSP/Liberty, but it will affect it once a rebase for a new tarball occurs. This affects all OSP/Mitaka installations.


How reproducible: always.


Steps to Reproduce:
- observe that br-int mtu = 1500
- create vlan network (mtu = 1450)
- start a nova instance using vlan network
- observe br-int mtu is now 1450
- create gre network (1458) with a subnet
- plug in the gre subnet into the router
- observe that qr device in qrouter namespace for gre network is 1450 (not 1458 as expected)


Expected results: MTU on qr device reflects network MTU.

The issue is fixed in upstream with: https://review.openstack.org/#/q/Ibd9866d2d8fe12bb253c6fb9978f583293b32734,n,z

Comment 2 Ihar Hrachyshka 2016-06-20 08:20:54 UTC
Note: this bug assumes network_device_mtu is not set on Nova or Neutron.

Comment 3 Ihar Hrachyshka 2016-08-10 07:58:15 UTC

*** This bug has been marked as a duplicate of bug 1365622 ***


Note You need to log in before you can comment on or make changes to this bug.