Bug 1365622 - ovs: set device MTU after it's moved into a namespace
Summary: ovs: set device MTU after it's moved into a namespace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Ihar Hrachyshka
QA Contact: Toni Freger
URL:
Whiteboard:
: 1348115 (view as bug list)
Depends On:
Blocks: 1348116 1365153
TreeView+ depends on / blocked
 
Reported: 2016-08-09 17:30 UTC by Nir Yechiel
Modified: 2016-08-24 12:57 UTC (History)
8 users (show)

Fixed In Version: openstack-neutron-8.1.2-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-24 12:57:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1365153 None None None Never
Red Hat Product Errata RHBA-2016:1759 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2016-08-24 16:50:04 UTC

Internal Links: 1365153

Description Nir Yechiel 2016-08-09 17:30:35 UTC
Description of problem:

Open vSwitch forbids to raise MTU for devices that are in the same namespace with the bridge, but allows that same operation once the device in question is moved into another namespace. This is a side effect of missing validation in vswitchd implementation for plugged interfaces located in other namespaces. This effectively lowers MTU for router interfaces from what is supported by underlying physical interfaces. With that, frames from an external network of infrastructure MTU size will not be served by affected routers.


Expected results:

The fix reverses the order of interface plugging procedure steps, first moving ports into namespaces, then setting their MTUs. This seems to solve the issue.

Comment 2 Ihar Hrachyshka 2016-08-10 07:58:15 UTC
*** Bug 1348115 has been marked as a duplicate of this bug. ***

Comment 4 Toni Freger 2016-08-23 11:26:12 UTC
Code tested on latest  puddle, openstack-neutron-8.1.2-3.el7ost

Comment 6 errata-xmlrpc 2016-08-24 12:57:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1759.html


Note You need to log in before you can comment on or make changes to this bug.