Bug 134812 - ICE compiling qt-gui plugin for licq
ICE compiling qt-gui plugin for licq
Status: CLOSED DUPLICATE of bug 134676
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 10:25 EDT by Vladimir Kondratiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source, as requested in error message (248.02 KB, application/x-bzip2)
2004-10-06 10:31 EDT, Vladimir Kondratiev
no flags Details

  None (edit)
Description Vladimir Kondratiev 2004-10-06 10:25:41 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
When compiling qt-gui plugin for licq (version 1.3.0); 
ICE occurs. 
 
Version-Release number of selected component (if applicable): 
gcc-3.4.2-4 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.get licq 1.3.0 from www.licq.org; unpack 
2. `./configure && make` in licq 
3. `./configure --with-kde && make` in plugins/qt-gui 
     
 
Actual Results:  ICE: 
 
if /bin/sh ../libtool --silent --silent --mode=compile --tag=CXX g++ 
-DHAVE_CONFIG_H -I. -I. -I..  -D_REENTRANT -I/tmp/licq-1.3.0/include 
-I/usr/X11R6/include -I/usr/lib/qt-3.3/include -I/usr/include/kde 
-fPIC -DPIC -D_REENTRANT  -O2 -fno-exceptions -fno-check-new -Wall 
-I/usr/lib/qt-3.3/include  -I/usr/X11R6/include-MT chatdlg.lo -MD -MP 
-MF ".deps/chatdlg.Tpo" \ 
          -c -o chatdlg.lo `test -f 'chatdlg.cpp' || echo 
'./'`chatdlg.cpp; \ 
        then mv -f ".deps/chatdlg.Tpo" ".deps/chatdlg.Plo"; \ 
        else rm -f ".deps/chatdlg.Tpo"; exit 1; \ 
        fi 
In file included from /usr/include/kde/kservicetype.h:24, 
                 from /usr/include/kde/kmimetype.h:35, 
                 from /usr/include/kde/kfiledialog.h:34, 
                 from chatdlg.cpp:47: 
/usr/include/kde/ksycocaentry.h: In constructor 
`KSycocaEntry::KSycocaEntry(QDataStream&, int)': 
/usr/include/kde/ksycocaentry.h:66: internal compiler error: 
Segmentation fault 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions. 
Preprocessed source stored into /tmp/ccEzo5FS.out file, please attach 
this to your bugreport. 
make[2]: *** [chatdlg.lo] Error 1 
make[2]: Leaving directory `/tmp/licq-1.3.0/plugins/qt-gui/src' 
make[1]: *** [all-recursive] Error 1 
make[1]: Leaving directory `/tmp/licq-1.3.0/plugins/qt-gui' 
make: *** [all] Error 2 
 
 
Expected Results:  Compiled OK 
 
Additional info: 
All packages installed are as of "development" Fedora Core of Oct 6
Comment 1 Vladimir Kondratiev 2004-10-06 10:31:05 EDT
Created attachment 104838 [details]
Preprocessed source, as requested in error message
Comment 2 Bill Nottingham 2004-10-06 13:10:15 EDT

*** This bug has been marked as a duplicate of 134676 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.